Spotify skipping all songs

Solved!
Reply

Spotify skipping all songs

Altaira
Casual Listener

Plan

Premium

Country

Poland

Device

PC

Operating System

Windows 10

 

My Question or Issue

Spotify is skipping all songs in playlists. If I try to play one song I have an "Spotify can't play that now" error. I've tried to restart app/pc. I've reinstalled my audio drivers (I use audio extension card: ASUS XONAR DG). Switich/turing on and off output and input devices doesn't work. Some of these fixed work for once, but the problem in coming bach and now I can't get Spotify to play anything.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

mran1044
Regular

For those of you with an ASUS Xonar DG sound card or similar and have recently been unable to use Spotify on your Windows 10 PC as of the last several days I saw a post Virmiculum posted where he/she went into the Xonar Audio Center (sound card software on your computer) and disabled the DSP Mode. I checked mine and had the GSX under DSP mode highlighted in green. It never affected Spotify in the past several years but it appears to cause the recent issue of constantly skipping around to different songs before it can even start playing a song.

 

After turning off all DSP options and then closing and restarting Spotify I am back in business!!!! I did not change settings before that so I think Spotify just recently started to not like DSP settings being turned on. Hope this helps some others people as it worked for me.

View solution in original post

Xonar DG Audio Center- DSP MODE OFF.jpg
Solution!

Altaira
Casual Listener

Uninstalling Windows update worked for me!

View solution in original post

21 Replies

MichaelJerzak
Composer
Have you tried logging out and back in? Maybe check the cache on your computer?

mran1044
Regular

Hi I started having the same issues. I think it may of started after I updated my Windows 10 update to a later version yesterday.  I also have the Asus Xonar DG sound card which has been working fine for years. Spotify keeps skipping songs and they do not play. Spotify just jumps from track to track. My other desktop Windows 10 is working fine and my Android is working fine. I need this to work on my main desktop so it is an issue.

Altaira
Casual Listener

Hey. I've tried logging out. What cache do you have in mind?

Solution!

mran1044
Regular

For those of you with an ASUS Xonar DG sound card or similar and have recently been unable to use Spotify on your Windows 10 PC as of the last several days I saw a post Virmiculum posted where he/she went into the Xonar Audio Center (sound card software on your computer) and disabled the DSP Mode. I checked mine and had the GSX under DSP mode highlighted in green. It never affected Spotify in the past several years but it appears to cause the recent issue of constantly skipping around to different songs before it can even start playing a song.

 

After turning off all DSP options and then closing and restarting Spotify I am back in business!!!! I did not change settings before that so I think Spotify just recently started to not like DSP settings being turned on. Hope this helps some others people as it worked for me.

View solution in original post

Xonar DG Audio Center- DSP MODE OFF.jpg
Solution!

Altaira
Casual Listener

Uninstalling Windows update worked for me!

View solution in original post

Altaira
Casual Listener
Maybe I'll try that but for now I've unistalled last windows update and it worked.

Spilly
Casual Listener

Thank you very much, switching off GX DSP mode fixed the problem Spotify was having.

mran1044
Regular

You are welcome glad it helped!

calexandre
Newbie

Thank you sir! This issue was driving me nuts...

Menkar
Visitor

You are a godsent. I couldn't find out what was wrong with the app for 2 months, and it finally works fine now !

saetlan
Casual Listener
Thank you! it worked for me

spotmauri
Visitor

scusate per la lingua ma grazie 1000 ho perso ore per risolvere questo problema collegato allo xonar DGX della asus mai piu' schede audio della ASUS.
Non è il primo problema che mi ha dato.
Grazie ancora !!!

Tom013
Casual Listener
Thanks! This worked out for me!

eltwinne89
Regular

Are you able to listen in 5.1, 7.1 mode? I have the Xonar DX and GX in DSP mode enables this configuration for surround sound. Disabling it allows songs to be played, but removes this surround feature. On the other hand if i enable DSP i can only play my local files in surround, it skips all the rest of the online songs... Im starting to get tired of spotify

ironpi
Newbie

ASUS Xonar DG sound card issue was the exact issue that I was having. 

Changing the setting to "on" fixed it for me. The setting was already turned off when I checked.

 

Some interesting notes though:

  • Using another account did have the issue when first logging in.
  • Immediately after a spotify update the issue did not occur until the PC was restarted. 

eltwinne89
Regular

Still having this issue. Where you guys able to fix it? I mean, disabling DSP is not a real fix, it takes away all sorround sound away so...

 

Please need support from Spotify!!!

tris_l
Newbie

Thank you!  This solved it!!

mfalla
Newbie

Nice one. Thanks. This has been bugging me for weeks! 

 

Occultor
Visitor
This solved my issue!! Thanks!
SUGGESTED POSTS