Windows 10 disable auto startup

Reply
Highlighted

Windows 10 disable auto startup

Regular

Plan

Premium

Country

Sweden

Device

PC

Operating System

Windows 10

Version

1.0.87.491.ge2a121fc (Windows Store version)

My Question or Issue

Hi,

Spotify keeps opening up on startup even though I have changed all the settings I can think of, help?

Thanks!

2018-08-12_17h17_42.png
9 Replies
Highlighted

Re: Windows 10 disable auto startup

Roadie

Hey @marcelo_7, welcome to the Community!

 

Sorry to hear you're having trouble with this. We'll do our best to help though.

 

How long has this been going on for? Does the issue persist after a quick reinstall? You can find the steps on how to do this here.

 

Hope that helps.

Highlighted

Re: Windows 10 disable auto startup

Regular
Hi!

It did not help.

I unistalled, reinstalled.
The settings had been reset so I selected "No" in the autostart dropdown.
Before reboot I could see it was set as Disabled in the Task Manager.
Reboot.
Spotify opens at startup.

I am not sure how long but a couple updates at least. Let's say 3 months
(but it's probably more).


Best regards,
Marcelo
Highlighted

Re: Windows 10 disable auto startup

Roadie

Hey @marcelo_7.

 

Thanks for getting back to us. 

 

In this case, we'd like you to try the following steps:

  1. Go to Task Manager and kill SpotifyWebHelper.exe process.
  2. Go to C:\Users\<username>\AppData\Roaming\Spotify and delete SpotifyWebHelper.exe.
  3. Go to MSCONFIG and make sure Spotify is disabled under the Startup tab
  4. Restart your PC and see if the issue persists.

Let us know how it goes.

Highlighted

Re: Windows 10 disable auto startup

Newbie

Hi,

 

To disable Spotify Autostart in Windows 10.

Right click Spotify start menu shortcut, Choose More, App Settings.

Capture.JPG

Click Configure startup tasks,  locate spotify and turn the switch to off.

Capture1.JPG

Highlighted

Re: Windows 10 disable auto startup

Regular

Hi!

I have not had time to do the last thing you proposed but for some reason it works now a week later. I don't understand it but my problem is solved. 

 

Thanks!

Highlighted

Re: Windows 10 disable auto startup

Regular

I think that setting you propose is the same one from my screenshot.
It was off when i checked it your way.

Highlighted

Re: Windows 10 disable auto startup

Newbie

This is Windows 10. You go to the Startup tab in the Task Manager to disable startup items. MSCONFIG is no longer used for this task. (Win10 v1903)

Highlighted

Re: Windows 10 disable auto startup

Casual Listener

I have the same problem. Disabled startup in both Spotify and Task Manager but no luck. The process SpotifyWebHelper.exe is not in my system. I'm running the Windows 10 Store App version btw.

 

James

Highlighted

Re: Windows 10 disable auto startup

Newbie

I've resolved it this way:

  1. close Spotify (also in Windows tray)
  2. go to folder where Spotify intalled (for me it's C:\Users\MyUserName\AppData\Roaming\Spotify)
  3. backup the file "prefs", like "prefs"->"prefs.bak" (if something goes wrong)
  4. run Spotify - you should see the "Sign in" form
  5. login into your account
  6. and configure again the Spotify
  7. also I changed "cache directory" and Spotify suggested me to reboot the program, after reboot the program and reboot my PC the issue was resolved
SUGGESTED POSTS