Help Wizard

Step 1


Support Windows 10 Change-Volume-UI




When using the volume knob/button on keyboard in Windows 10 and a song is playing in Windows Media Player, it looks like in the image above. Not only does the systems volume level indicator show up, but also the current song with metadata, cover art and simple controls.


It would be really great if music playing in Spotify showed up here too.

Updated: 2016-11-29


How do I deactivate this?? It's a horrid feature, it comes up during playing games and disturbs me/covers the screen! I am unsubscibing my premium if I can't fix this!


Thank you for making the media overlay controls/UI optional!! With this feature enabled I could not use the "Stop" key on my MS wireless media keyboard anymore (and I have been using it to stop songs on Spotify for YEARS).  Now I can disable the overlay feature and I'm able to use the Stop key again 🙂  In addition - the way the overlay stays on top of all other windows for a fixed amount of time is a dumb idea by MS anyway....


Is there any way to disable this? I loathe this function and have found it incredibly frustrating ever since it was introduced - it was the solution to a problem that I never had. 


In order to disable this feature, open Spotify, select the Edit menu and open the Preferences.... Scroll down to the Display Options and uncheck the Show desktop overlay when using media keys.


Agreed, Also a larger volume slider for subtle changes


On my Windows 10 laptop, I *DO* get the whatever Spotify is playing showing up when I access the volume controls from the keyboard..

Spotify volume.jpg


BUT, when casting from Sporify in Windows to my Chromecast Audio, NOTHING affects the volume (neither the hardware volume controls on the keyboard, or any of the sliders in the taskbar Volumes Mixer panel.


The ONLY way I can adjust the volume is to go back to my Android phone, fire up Spotify there and use the hardware buttons (while the Spotify app is maximised on screen).

Please, please please give us back a simple onscreen volume control for Spotify itself on every device, including when casting. This current mess is driving me mad.


This would also hopefully fix the weird volume creep that happens with Windows 10.


This would also hopefully fix the weird volume creep that happens with Windows 10.


I am using version and even after i switch this off, the next time i open spotify it is enabled again, even in the settings it is switched off.


Please fix 


It's still doing it, changing it in options does not help, after restarting spotify it's enabled again 😞