Lineup Signup
Hi! We're just rearranging some Desktop boards to make it easier to find what you're looking for. Please bear with us, and we'll be done very soon.
To post a new question or issue, please go here: Desktop (Windows), Desktop (Mac), Desktop (Linux), Web Player.

Opera Browser & Web Player

Reply

Opera Browser & Web Player

rast
Newbie

My homebase of browsers is Opera, but recently Spotify web player has stopped working on it. It skips every song after exactly 6 seconds. It's not Opera's VPN, adblocker extension, flash extension, or any other settings, as I've turned everything off and had the same problem. Chrome works fine so I'm using that for Spotify, but I would like to be able to use Spotify on Opera again. Any ideas on what's going wrong?

6 Replies

Re: Opera Browser & Web Player

RodrigoPalma
Roadie

Hey @rast, welcome to the Spotify Community!

 

We’d like you to try a couple of thing first. Can you let us know if using private browsing helps? We’ll see what we can suggest.

 

We’ll be waiting for your answer.

Re: Opera Browser & Web Player

MyMind
Newbie

This was happening to me and it turned out to be the VPN. However, just switching it off was not enough; I also had to reload the page.

Re: Opera Browser & Web Player

untipocreativo
Newbie

It worked for me. When I'm in private mode it works but if I'm not it doesn't play any song. A pink message appears on top wich says there was a problem and it remains not working. How can I solve it?

Captura de pantalla 2017-10-18 a las 18.06.20.jpg

Re: Opera Browser & Web Player

hans-jürgen
Roadie

For me the new web player in stable Opera versions works fine, but you need to install the Adobe Flash plugin for Opera and disable your adblocker, otherwise it will stop when an ad cannot be played.

 

By the way, scrobbling to Last.fm with this combo just got easier, see my posting from yesterday.

 

Re: Opera Browser & Web Player

soradevin
Newbie

I had this same problem. It was being caused by having opera turbo mode turned on. Turned it off and it worked perfectly again.

Re: Opera Browser & Web Player

FlyingSquirrel2
Newbie

Thank you soradevin - fixed it for me. 

In Opera go to settings and type "Turbo" in the search box. You will see the setting and can turn it off. Thern reload (F5) the Spotify page.

SUGGESTED POSTS