Web Player not working in Chrome - buttons misbehaving

Solved!
Reply

Web Player not working in Chrome - buttons misbehaving

thepest
Music Fan

Morning,

 

I've used Web Player for years at work, as downloads are locked on our office network.


Since last week the Web Player is working correctly in every way except it won't play anything!
I can search, browse albums/playlists, add tracks to playlists, but as soon as I try to hit a Play button nothing happens.


It's as if the button just doesn't work.


All the buttons in the play bar at the bottom of the screen are equally useless. Shuffle is currently on but a click does nothing, it just remains green.

 

Any ideas?


I've already followed all the troubleshooting guides I can find.

I'm running Chrome browser on Windows 8.1.

 

Thanks

1 ACCEPTED SOLUTION
Solution!

thepest
Music Fan

Fixed it!

I'm not exactly sure what the steps were and not convinced I could easily replicate it but it seems to be something to do with Spotify Connect and using multiple devices.

I got home last night and tried the Web Player and was having the same issue on my home laptop.

Not something I normally do at home as I cast from my phone. 

 

I switch between a few different ways of listening (phone, Chromecast, Web Player, Roberts radio) and it looks like that might have confused it the Web Player. 

 

From my phone, I tried switching between a few devices and that seemed to sort it out. Web Player now working perfectly.

 

Thanks for all your help.

 

View solution in original post

30 Replies

8n-g3g_u3ul7k
Newbie

Same problem.

Copied my webplayer link into an incognito window and it worked immeditaly.

Went back to my normal window, refreshed. boom.

Back to normal.  

PPSOD
Newbie

Hi, my web player is not working (song will stop halfway and won't be able to play anymore) despite i have tried different ways. My spotify app in my phone works well totally. 

 

Can someone advise in this? 

Trollishouse
Newbie

Still seem to be having an issue, none of the buttons are responsive and I can't even choose the "Web Player" inside of my phone's spotify

levinekb
Newbie

The suggestion of switching back and forth between devices isn't working for me. Am I doing something wrong? I'm on a Mac, lastest update before High Sierra.

Nico
Community Legend

Hey @thepest! ^^

 

That doesn't sound nice.

Have you tried this?:

  1. In Chrome go to yout toolbar, tap More.
  2. Tap History, and then tap Clear browsing data.
  3. Under "Clear browsing data," select the checkboxes for Cookies and site data and Cached images and files.
  4. Use the menu at the top to select the amount of data that you want to delete. 
  5. Tap Clear browsing data.

Let me know if that helps, thanks! ^^

Peace

thepest
Music Fan

No luck, Nico. Still not working.

 

Thanks for the suggestion though.

 

 

Nico
Community Legend

@thepest

 

I've escalated your issue to the support.

I will reply on this thread with help soon. ^^

 

Peace

Nico
Community Legend

@thepest

 

Can you try to use the web player with an incognito window?

 

Thanks! ^^

Peace

thepest
Music Fan

No, that's not worked either.

I've checked a couple of other people in the office that I know use Web Player and it's working fine for them.

 

 

Nico
Community Legend

Hey @thepest!

 

Sorry, for the long delay.

Do you have the ability to try an alternate web browser on the work computer?

Can you talk to your IT department in the workplace, to see if they've changed any settings recently. This might have triggered something that started this occurence from their end.

 

Let me know how it goes! ^^

Peace

 

Solution!

thepest
Music Fan

Fixed it!

I'm not exactly sure what the steps were and not convinced I could easily replicate it but it seems to be something to do with Spotify Connect and using multiple devices.

I got home last night and tried the Web Player and was having the same issue on my home laptop.

Not something I normally do at home as I cast from my phone. 

 

I switch between a few different ways of listening (phone, Chromecast, Web Player, Roberts radio) and it looks like that might have confused it the Web Player. 

 

From my phone, I tried switching between a few devices and that seemed to sort it out. Web Player now working perfectly.

 

Thanks for all your help.

 

View solution in original post

jarflores
Casual Listener

I have had the same issue.  When I get in to work everyday I initially try to start spotify via the browser.  Sometimes it will start playing, sometimes nothing happens when I press the "play" button for any play list, song, etc..

 

However, I recently installed the desktop client on the same computer where I try to use spotify via the browser.  When the browser doesn't work, I'll open the desktop client and start playing the music there and it works!  In addition, the browser picks this up and shows what I'm listening to.  After this, the browser works fine.

 

Not exactly sure what the issue could be, but somehow the browser gets "stalled" when the other clients do not.  I do see some errors in the browser console:
---
Failed to load resource: net::ERR_FILE_NOT_FOUND  blob:https://open.spotify.com/6cd5d5ad-bfb7-42b0-9967-f1926fc8facb:1

Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-eval' open.scdn.co www.google-analytics.com cdn.ravenjs.com vt.myvisualiq.net www.gstatic.com". Either the 'unsafe-inline' keyword, a hash ('sha256-exNIbRoBufGA8Xw81IIBBDk1C1yh5NkucdznLehlx2g='), or a nonce ('nonce-...') is required to enable inline execution.
---
But not sure they're related

briguy89
Newbie

Launching in an incognito tab and then switching back to the regular tab works as well for me. Clearly Chrome doesn't like something by default unless incognito or app-level validation also occurs. Lousy coding.

SkiCop
Newbie

I've tried everything in this string and it still is not working

i give up. work network is very locked down. used to work

now not. guess i will use my phone 😞

rekle
Roadie

What happened again? I log in to my account and before even hit play or load my playlist or whatever it shows a blank black screen and you can't do anything... tried everything nothing works. Chrome, FF. All latest... i ha started to be a lot angry with all the issues, the spotify for me doesn't exist anymore. I literally give up!

rekle
Roadie

Ok here is what i did and looks that works. I noticed misbehaving between spotify and google ads(visual).

1. I ended my chrome from task manager "End Task"

2. Clean my chrome cache with CCleaner.

I restarted my machine and till now works again... i hope it will last.

AntiBallermann
Newbie

I have the same issue

 

Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-eval' open.scdn.co www.google-analytics.com cdn.ravenjs.com vt.myvisualiq.net www.gstatic.com". Either the 'unsafe-inline' keyword, a hash ('sha256-exNIbRoBufGA8Xw81IIBBDk1C1yh5NkucdznLehlx2g='), or a nonce ('nonce-...') is required to enable inline execution.

2api.spotify.com/v1/episodes/meta:1 Failed to load resource: the server responded with a status of 400 ()

jarflores
Casual Listener

I should also note that in the scenario above, when the browser is NOT working, I do not see any other "sources" where I can play the music.  Even when the browser is the only client open to a user's account, it seems like that should show in one of the sources.

thegr8grace
Newbie

Anyone have a workaround for a web player that's not connected via wifi???

Sure the switiching devices method works well if you're on the same netework. I work for the govt., so we are pretty locked down.

sam1123
Newbie

I had exactly the same issue here, I switched source on my PC to my PC, but I needed to go to my phone which had the app installed and also change the source to PC on my phone, it seems that the web player and other devices have trouble with syncing settings

SUGGESTED POSTS