Data saver does not work with Android Auto

Reply

Data saver does not work with Android Auto

punguy_69
Casual Listener

Plan

Premium

Country

Canada

Device

Galaxy S8

Operating System

Android 9

 

When I use Spotify with Android Auto the data usage is very high, despite the data saver being enabled.

At work, I can stream over LTE for 5 hours or so and use maybe 50MB. When I'm in the car, using Android Auto, the data usage jumps by about 10MB every 20 min.

 

The data saver feature is clearly not working with Android Auto - like it's being disabled. I've tried everything, reinstalled the app (clean reinstall), reinstalled Android Auto all without success.

 

3 Replies

CarlosE
Moderator
Moderator

Hi there @punguy_69

 

Thanks for reaching out to the Community and welcome!

 

To check if this is indeed related to Android Auto, could you try connecting your phone to your car's stereo using a different type of connection, like Bluetooth or USB/Aux cable to see if this behavior persists?

 

If possible, also try using Android Auto with a different phone to see if the same happens. This way we can check if it's rather related to the phone.

 

Keep us posted.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

punguy_69
Casual Listener

I don't have another phone I can try, but I did connect via the regular Bluetooth connection and the data usage was definitely less. 

 

I may have found something of interest though. If I turn off Spotify's data saver, set the mobile streaming quality to low (rather than automatic) I get much lower data usage when connected to Android Auto. With the data saver on and quality set to automatic (which should be the same as manually setting quality to low) is when the data usage spikes. 

MafeG
Moderator
Moderator

Hi @punguy_69,

 

Thank you for your reply and sharing those insights. 

 

Certainly the Data Saver feature reduces the streaming quality automatically when connected to mobile data. 

 

We'd like to investigate this further, so please try the following:

  1. Go to your phone's Settings 
  2. Then open Battery > Battery Optimization.
  3. Search for Spotify and select "Don't Optimize"
  4. Then activate again the Data Saver feature and test if it's working correctly.

Keep us posted.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“When the power of love overcomes the love of power, the world will know peace. - Jimi Hendrix
SUGGESTED POSTS