Help Wizard

Step 1

NEXT STEP

Denon AVR-X2100W - No Spotify Connect

Solved!

Denon AVR-X2100W - No Spotify Connect

Just purchased a new Denon receiver and everything is working OK except Spotify connect, it doesn't show as a device on the connect page. I can stream everything via AirPlay OK, but connect doesn't show. They are both running on the same network, but I wonder if there are any settings I need to consider for spotify specifically. I have tried searching the forums but haven't come up with anything so far. If anyone could point me in the direction of some help it would be much appreciated!

Reply
505 Replies

This only works on your specific model Denon AVR. The buttons held differ from model to model.

If you can't find out how to reset tour receiver's internet connection, another option that MIGHT work is to manually select a different IP address for your receiver. I'm not sure how well that works for Spotify connect issues.

Today it doesn't work at all for me. Refuses to start playback.

Same for me here with X5200W, and tried all suggestions above (re-init, other network, wifi and ethernet cable, reset, other spotify accounts, re-install of apps,...).

I've got a family account, but none of my family members including myself can now connect to my denon. I can't see the Denon in the Spotify available instruments to connect, as well from my iphone, ipad, android tablet and mac computer.

this happened suddenly with no local changes in my configuration here.

In the meantime the only way around for me is to use my chromecast to play my spotify but it's really a pity and a shame as this is recurrently occuring since more than one year and support doesn't seem able to fix it on the long term.

I still cant get my Denon AVR X2100W to work with Spotify Connect?

Anyone who has tried a Deep Reset?

FACTORY RESETTING (deep reset)  1.Switch Off unit using main units POWER switch    2. Press and hold both ZONE 2 SOURCE SELECT and  DIMMER  buttons and turn On the unit by pressing main units POWER switch   3. Check that the entire display is flashing in 1 second intervals and then release the two buttons- the microprocessor will now be initialized/reset

As if yesterday Spotify is working again on both DENON X4100W and DENIN CEOL N4. Very interesting.
One device is with fixed IP the other on DHCP. One is with Google DNS, other on local internet provider.
What has changed in the meantime my side is a new Spotify IOS app release. That's all. I doubt this is the trigger though.
Unlike all my previous experience changing Spotify from AVR to iPhone is seamless - fast and without losing even small fragment of the song. Strange but nice.
I more and more think all this is all related to Spotify IP and routing issues in various areas that somehow affect Spotify Connect. I am based in Sofia, Bulgaria.
Please share your experience.

AVR-X1100W and connect very good for a couple of weeks now. I did absolutely nothing. I think there was an Android app update but nohing else has changed in my end.

I have had the same problem on my Denon AVR-X4100W for a long long time, but recently I received a firmware update to version 6005-3195-6094-07. and now spottify connect is working perfectly!

Yesterday I got notification for a new firmware. Installed and Spotify back to working perfectly. Please no more untested firmwares Denon. 

 

For which model AVR?

Hi all, I just got an AVR X-1000 with the expectation that Spotify Connect would work easily but unfortunately no luch.  I've tried all the solutions I've come across so far (turning DHCP off with manual IP address input, resetting all devices, logging in and out of Spotify Premium account, factory reset of receiver) but the option for Spotify Connect still does not appear on my S8, or Spotify web browser.  I can play Spotify through the Denon app but it is awful.  Any tips?  Thanks!!

The X-x000 series does not support Spotify Connect, only the local (and pretty hard to handle) client in the AVR or the app

Doh!  Thank you for clarifying this.

I tend not to agree with suggested solution. 

-Do you know you need Spotify Premiium (paid) to use Spotify Connect?

-Also, try connecting AVR via LAN. Denon WiFi is 2.5 GHz only and it is pretty congested frequency especially if you leave in apartment building. 

- update Denon to latest firmware 

 

hope if help

Denon introduced Spotify Connect (and WiFi) with the X-x100 series. The X-x000 series has a native Spotify client which requires a login on the AVR or the app. However, the look and feel of the client is clumsy and it is also really slow. I once owned an X1000, believe me, I know what I speak about. I got the chance to upgrade because my Spotify client suddenly stopped working and Amazon offered me an upgrade.

As of yesterday, Oct 23, Spotify Connect is not working on my Denon AVR3100w. I unplugged it for a few seconds and still doesn't get detected on my phone or desktop app. It's been working fine for a year perhaps. What gives now?

Same issues here. Spotify connect was working fine from my Android phone and iPhone. After the last FW update I can't connect to my x1200. Apple airplay still works though.

 

Some days that my Spotify app on android does not see the avr.

It can see Sonos, Chromecast (which is connected in the back of the avr) but denon avr x21000X is not showed in the list of Spotify Connect devices. 

 

The avr is connected to wifi because I can access it via the app.

I was able to get mine to connect by resetting the network adapter after the last firmware update. 

 

I followed the process below while the input on the reciever was set to online music. After doing this the Denon showed up as connectable device in the Spotify app on Andriod and Apple. 

 

AVR X1100W / X2100W / X3100W: Hold down the "ZONE2 SOURCE" and "DIMMER" buttons simultaneously for at least 3 seconds.
AVR X1200W / X1300W / X2200W / X2300W / X3200W / X3300W: Hold down the "TUNER PRESET CH -" and "TUNER PRESET CH +" buttons simultaneously for at least 3 seconds.

I get it connected with my AVR X2400H but Spotify keeps repeating the song after 3/4 of the song. It's supper annoying.

Doesn't matter what I play (Radio, Album, Playlist) and if I skip a song manually it does the same to the now playing song. Repeat is obv. not active and it still does it.

 

I started Spotify using different sources and it's always the same when I play it via the AVR. If I just use the phone everything is fine.

Suggested posts