Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


New Web Player not working due to Widevine

New Web Player not working due to Widevine

Hello all,


I am using the Spotify Web Player at work as I'm not allowed to install any apps on the work system. This wasn't an issue as I the Spotify Web Player worked flawlessly... That is only up until the new design was rolled out. I'm using Frontmotion Firefox, which is the approved web browser. The is now permanently being redirected to, and the streaming does not work at all. Whenever I attempt to play any music, the plugin Widevine crashes. There is no way to make it work on my end.


Is there a fix to the Widevine crashing? Not sure what exactly is the technical reason for the crashing.

Can I revert the design to the old version of Web Player?


Please keep in mind that I am not allowed, or even able, to install or add any addons or applications.



17 Replies

Folks have had some luck using a browser extension to change the User-Agent to IE or Edge--I know you said that you were unable to do so. I shared the following link to do it without an extension for a guy to try on Chrome, which worked. You might be able to access the old web player using IE, but just be aware that Spotify is saying that the new player is the one for the future. We all must embrace change--even if it hurts, lol. I mean, we're all masochists--after all, we're on the internet. Hope this helps.




Thanks for the ideas. I have already seen this possibility on the web, unfortunately as I pointed out Frontmotion Firefox is the only approved web browser at my work, and I'm not allowed or able to install any addons / plugins.


I understand this is not ideal in the situation and will be difficult to resolve, but the idea here is that all worked fine prior to the upgrade, so essentially this is a downgrade for me, as well as some other users I'm sure.


This is creating a problem because I'm paying for a Premium Family service that I will not be able to use at times I used it the most.

I am not entirely familiar with FrontMotion Firefox (I use general Mozilla Firefox), but can you access your about:config data by typing it in your address bar?
It's pointed out how to modify the user-agent setting in there in the howtogeek link.



SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Well, phooey!


I was getting ready to respond but then I saw SebastVAIO's comment--which I would echo.


If indeed, you are unable to do that, grrrrr! Still looking for ideas, but in the meantime, can you share the name of your "concentration camp"? LOL


Here's hoping you have a good day.



Apologies, I was being dumb and not reading properly. I was able to get though to the settings in about:config and set up a new useragent value. I tried one from Chrome and one for IE:


Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Chrome/ Safari/525.19

Mozilla/4.0 (Windows; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727)


But neither worked, I'm still being redirected to Is there a different one that should work?


As for the workplace, I'd rather not disclose. 😉



Well, I guess we're working under the hood to get the old player working. Don't forget to embrace change (I don't like change either, lol)--because the old one is going away. From what I've seen, it looks like Internet Explorer 10 will do it with better results than IE 11 or Microsoft Edge. Here are some reference links which may help--all from the same website.


  1. One I picked from the IE 10 list for an example:
  2. The IE List:
  3. Main page:


No warranties! LOL


Good luck!




Thanks for still being with me here, hehe.


I tried that one and a couple of other ones I selected from the list, but none helped; all are still redirecting me to the new player sadly.


By the way it's not that I don't like change in general, it's only when the change is detrimental that I'm annoyed! 😛

Do you have administrator rights to your computer?
(although.. in companies it's unlikely, but worth asking anyway)...

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

No admin rights, the user rights are limited and I'm also using a Citrix station...

That's bad...
I guess, unless Spotify comes up with an update, you'll probably have to resort to mobile Spotify. Plug the device in power socket and let it play.



SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Grasping at straws here--not finding much due to your company's lovely setup. Here's a way to make sure Widevine is up-to-date--not sure if you will have control over it but it may be worth a shot.


Alternate Widevine Plugin Download Link

Unfortunately I'm having the same feeling. I'll try to see what can be done about Widevine. Thanks for your help!

Hi! I am back again. 🙂


Another user found a method that worked well for them.
There's a button for Devices near the Volume slider. Click on it and select 'Computer'. Reload page.
Maybe that works for you too.

Keep me posted. 🙂



SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

What I found working is going to Tools ->options->content-> de-selecting and selecting the DRM option, reloading spotify so that the warning message appears that firefox is installing needed extensions aaaaand its working.

(also on citrix)

Good luck

Hi, tried this as one of the first things, but did not work for me - there was no action done and this just froze the option in Firefox most likely due to restrictions on citrix as this required an installation of the plugin for Firefox (I suppose).


In the end this was resolved naturally with us getting Google Chrome, on which everything works quite well.

I had exactally the same problem. I toggled off the 'play DRM controlled content' in settings then refreshed the Spotify player then clicked the yellow warning bar to reenable DRM. that seemed to do the trick!

This worked for me as well.


The WideVine plugin kept crashing for me. I disabled DRM playback in options, reloaded the Spotify web player page, and click the enable DRM content button in the top right of the page. After that I was able to play Spotify in Firefox (58.0.1 64-Bit).

Suggested posts