WEBPLAYER - Play Button Greyed out

Solved!
Reply

WEBPLAYER - Play Button Greyed out

user-removed
Not applicable

Hi, i have a free acount and i primarily use spotify on google chrome and a few days ago the web player just stopped playing any music. i can nagivate to music and playlists etc but it does not play any songs. The play button is greyed out and unclickable. I tried relogging as well, didnt work. Then my friend(who has a premium account) logged in and the web player was working fine. I logged in with my own account(free) and it does not play music anymore. Is spotify now paid only?

 

Capture.PNG

4 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

Swanny
Community Legend
Hey everyone! Are you able to check and confirm that you are not playing any music on any other devices? It's possible that if other devices are playing music, the Web Player may leave itself disabled, as Connect is a premium-only feature.

View solution in original post

Solution!

ankitskywalker7
Newbie

SOLUTION: hey guys i heard some peoples problems were being fixed by checking they werent playing music on a different device, sadly this was not the case with mine.

i got in touch with spotify help centre and after trying their troubleshooting they gave me a test account to log in with and see if it worked if i was logged onto a different account. everything was fine when i logged in with the test account so the help centre guys just reset my account, got me to make a new account and transferred my music and other data from my old account over so everything is fine now.

TL:DR - old account is weird, made new account and spotify help centre transferred over all my data(music)

View solution in original post

Solution!

RonTheJapanese
Casual Listener

PC- Windows

Phone- Android

Browser- Google Chrome

I tried clearing cookies, using other browsers and restarting, diabling adblock etc. none worked

Spotify Webplayer on my PC didn't let me play, but my phone was fine.

SOLUTION

Here's a step by step way to fix it, i took screen shots and circled the important parts, get Spotify app for your phone, log in your Webplayer and Phone for Spotify.

Next on the APP play a song, then tap the up arrow "˄"

Then click devices available

Click Chrome Browser where you are logged in, if it doesn't show up click play on computer

Then play button won't be grayed out

Hope it works, if not try all the things I mentioned that didnt work for me.

RonTheJapanese

View solution in original post

broke.png
Untitled.png
work.png
Solution!

G00mbah
Newbie

I had the same problem, solutions given here didn't fix it for me. Tried clearing cache, logging in and out, other browsers, choosing my computer as the playback device.

 

What eventually worked for me was going to the account page (https://open.spotify.com/settings/account), then choosing 'Full website'. 

 

When on the full website, choose some music to play (it shows music you played recently). 

 

I was redirected back to the web player page and voila, it was playing music again.

View solution in original post

20 Replies

Sebasty
Rock Star 18
Rock Star 18

Hey @user-removed

 

That's unpleasant!

Have u tried deleting cookies+cache? Ctrl+F5 (thorough reload of the webpage) may be worth trying as well.

 

Playing music on Spotify is not a paid service, don't worry. I play music on the web player and I'm on free... 🙂

 

Keep me posted!

SebastyRock Star 18
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

magicpritt
Newbie

Having the exact same problem since last Friday: the play button is greyed out and I can't play any music (my playlists or Spotify's default playlists).

I tried relogging, changing browser, deleting Cookies and cache and refreshing the page with Ctrl+F5, but the play button still stays grey. 

I have a free account, too.

user-removed
Not applicable

Same problem - I even downloaded a new browser and tried it, and it still doesn't work. Also have a free account, not using an ad blocker, have tried two different computers and three differnt browsers, have deleted cookies, nothing. I think it's been about two weeks now. 

Solution!

Swanny
Community Legend
Hey everyone! Are you able to check and confirm that you are not playing any music on any other devices? It's possible that if other devices are playing music, the Web Player may leave itself disabled, as Connect is a premium-only feature.

View solution in original post

Furano
Newbie

advice was very helpful.

 

I started my smartphone's app and changed the device used for playback. Then, the problem was solved immediately.

 

Sorry for my poor English.(from Japan)

再生画面がグレー.png
再生画面が復活.png
Solution!

ankitskywalker7
Newbie

SOLUTION: hey guys i heard some peoples problems were being fixed by checking they werent playing music on a different device, sadly this was not the case with mine.

i got in touch with spotify help centre and after trying their troubleshooting they gave me a test account to log in with and see if it worked if i was logged onto a different account. everything was fine when i logged in with the test account so the help centre guys just reset my account, got me to make a new account and transferred my music and other data from my old account over so everything is fine now.

TL:DR - old account is weird, made new account and spotify help centre transferred over all my data(music)

View solution in original post

Swanny
Community Legend

Thanks @Furano, glad you got it sorted!

user-removed
Not applicable

I selected the option in my account to force log out of everything, and it still doesn't work. Not the solution I am looking for.

Solution!

RonTheJapanese
Casual Listener

PC- Windows

Phone- Android

Browser- Google Chrome

I tried clearing cookies, using other browsers and restarting, diabling adblock etc. none worked

Spotify Webplayer on my PC didn't let me play, but my phone was fine.

SOLUTION

Here's a step by step way to fix it, i took screen shots and circled the important parts, get Spotify app for your phone, log in your Webplayer and Phone for Spotify.

Next on the APP play a song, then tap the up arrow "˄"

Then click devices available

Click Chrome Browser where you are logged in, if it doesn't show up click play on computer

Then play button won't be grayed out

Hope it works, if not try all the things I mentioned that didnt work for me.

RonTheJapanese

View solution in original post

broke.png
Untitled.png
work.png

RonTheJapanese
Casual Listener

Hope it works

RonTheJapanese

7GS7
Newbie

That solved the pb for me 🙂

Solution!

G00mbah
Newbie

I had the same problem, solutions given here didn't fix it for me. Tried clearing cache, logging in and out, other browsers, choosing my computer as the playback device.

 

What eventually worked for me was going to the account page (https://open.spotify.com/settings/account), then choosing 'Full website'. 

 

When on the full website, choose some music to play (it shows music you played recently). 

 

I was redirected back to the web player page and voila, it was playing music again.

View solution in original post

unnamed
Casual Listener

 

This solution does not always work. Spotify increasingly works worse, with each new feature becomes more and more difficult to listen to music.

 

There are a lot of other apps that work very very fine: Last.fm, Pandora, Deezer

GotSpotifyBack
Newbie

@G00mbah: This worked for me too.  I saw one of my playlists and a few suggested playlists.  I clicked on mine and it didn't work.  I tried again with one of their suggested playlists and it worked!


I closed it all out and reopened the web player from my bookmark and it works with all my playlists.

 

Previously, I tried all the other methods mentioned (except creating a new account) and none worked.  I was without S for about 4 weeks. Thank goodness for P!

unnamed
Casual Listener

these steps sometimes work and many other times not. I think the web application should be disconnected from our mobiles.

Wollow
Newbie

This is the one thing that worked for me after days of trying all this **bleep**. You are doing Gods work.

merlynmoon
Newbie

None of those worked and my play button is still greyed out 

masonricard
Newbie

I had this problem, it wouldn't play on my laptop with a Chrome OS. I opened Spotify on my phone, went to settings, in devices, there is an option 'connect to device', in that I clicked on the other device (my laptop). When I closed Spotify on my phone, my computer worked fine. Hope this helps to anyone with the same problem. 

user-removed
Not applicable

That worked for me! Thank you so, so much! 🙂

SUGGESTED POSTS