Announcements

Having trouble seeing your Wrapped stories? To fix this, update the Spotify app to the latest version.

Find more info on our community FAQ.

Web player won't play and keep asking to login

Web player won't play and keep asking to login

My Web player always asks me to press "Login" button every time i opened it (even when i saved my password and "remember me" option checked), and then wont play anything. It happedned on every browser: Chrome, Edge, Firefox. 

You can see my problem here: https://youtu.be/Lrs0l9D7fg0


I've tried to:
- Clear cache and cookies

- Switch between other devices.

- Sign out everywhere and re-login

- Try "Full website" option

Nothing worked.

This is driving me crazy. Please help!!!

Untitled.png
Untitled2.png
Reply
17 Replies

Hello, you could try it with another Spotify account and look, if the problem persists.

 

Have you Widevine enabled?

Widevine is used for the content protection. It is normally enabled on most browsers.

 

What device are you using?

My Android Spotify app is working fine, this problem only happened on Desktop Web player.

I used default setting on every browser: Chrome, Edge, Firefox, so yes i think.

You could still try creating another Spotify account, so you see if it is a account specific problem.

 

If nothing helps, you could use the Spotify Offline Player (it‘s available in the Windows Store or on the Spotify website)...

Have you enabled an ad blocker or a firewall? Try disabling it...

 

You have to have Adobe Flash Player installed and enabled for the Spotify Web Player.

No i dont have any ad blocker or firewall. Adobe Flash Player goes with these browser by default, i had it turned on of course.
Thank you for helping, but there isn't any useful information for me 😞

If you have Twitter, you could tweet @SpotifyCares to get Support.

 

Can you play songs by link?

Hey 🙂

 

@this1marcel
Just a FYI - the Spotify web player doesn't need Flash anymore. The old web player did need Flash to work, but not the new HTML5 player.

 

@QuangHuy

I do suggest checking if the Widewine is enabled.
On Firefox, go to About:Preferences and under the General tab there should be a tickbox for Widewine content. Make sure it's enabled. About:plugins should show you if you have it installed at all. About:addons has a Plugins tab, there it's also possible to activate it. Make sure it's set to "Always Activate"

 

Then you can try this:
Go to Spotify webpage, log in if you're not logged in yet and select any album in the "Jump back in" section. This should open the web player and make it play the album you selected. 🙂

 

Keep me posted!

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

@Sebasty Oh yes, sorry I forgot that the Web Player doesn't need Flash anymore... 😞

On Chrome you can go to chrome://components and enable or update the Widevine plugin.

 

You could also try opening Chrome as administrator.

 

You can also check this.

Hi @Sebasty

My Widewine is enabled and updated. I've tried your trick too many times before, it won't help.

Everytime i hit an album in the "Jump back in" section, it showed "LOGIN WITH SPOTIFY" request.

Untitled.png

@QuangHuy

 

Pretty interesting! I've never seen that kind of login screen in my end.

 

I suggest trying another network. Create a hotspot with your mobile and try then.

You can also try restarting your router. 🙂

 

What operating system is your computer running?

If you're using a third party antivirus / antimalware program, make sure that's not blocking Spotify.

 

Keep me in the loop!

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Hi @

 

My computer is running on Windows 10 Creator without any third party antivirus / antimalware program. Since i faced the problem, i've reinstalled my Windows.

I just connect it to my mobile hotspot and it still doesn't work.

May it be an account problem? My PC app and Android app are working fine.

Try going to https://www.spotify.com/us/account/apps/ and disabling access for all 3rd party apps.

Thank you @this1marcel for being patient with me. I revoked them all, sadly it won't help 😞

I am encountering the exact same problem as well. In my case, all browsers (Firefox, edge, chrome) have the same issue and I've tried multiple accounts.

 

However, another computer on a different network worked fine.

 

I'm not sure, but seems to be pointing to a network or computer-specific problem?

@hawkomics

 

If possible, could you try plugging your computer to that different network as well?

 

Hosts file may be a culprit. Take a look at this guide (HowToGeek) on how to check it.

Make sure there are no entries with Spotify or Fastly in it.

 

You can also try flushing DNS records:

Run Command Prompt as an admin and type in the following command:

ipconfig /flushdns

And hit Enter.

 

Keep me posted!

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

I'm having the same issues. I use Opera version 52. The exact same issue. I even allowed the spotify website and exception on my flash player. HELP!!! It was working fine yesterday, I did nothing to change anything.

I have flushed my dns, cleared all of my cookies / browsing history, all of it and nothing seems to have worked yet.

 

EDIT: Wow it just randomly started working again. Weird.

Suggested posts