Help Wizard

Step 1


Amazon Echo name changed to some serial number

Amazon Echo name changed to some serial number






Amazon Echo Dot 3gen

Operating System

Windows 10


My Question or Issue

Since yesterday when I request the available devices via API Reference, I receive this:


"id": "d0e0c8da-1a4b-4b72-b7ff-4f089fd41d92",
"is_active": true,
"is_private_session": false,
"is_restricted": false,
"name": "d0e0c8da-1a4b-4b72-b7ff-4f089fd41d92",
"type": "Speaker",
"volume_percent": 36

However when I open spotify app on my phone or the windows app on my computer, then the name is correct. (It should be "Echo Dot")

 I have tried to rename and device and deregister the device and reconfigure in the alexa app, but it did not help.

62 Replies

Hi everyone


I wanted to circle back and provide an update on this issue.


We acknowledge this problem and this is indeed something that needs fixing on our end. Unfortunately the solution is not straight forward, but we are working on it.


I'm hoping to return with good news soon. Thank you for your patience. 

Thanks for the update. it's nice to know you are on the case.

first of all I would like to say thank you for this very good news.

I'm already looking forward to everything working properly soon.


and I hope that the elimination of the problem does not take as long as the insight took.



again 4 weeks have passed.
again nothing happened.

will Spotify give us a Christmas present?

Same issue over here. Thought I was going a bit mad until I found this thread. I have fourth gens and they keep disappearing. When I get them to register again they have UUIDs for names.

I asked for a working API from Santa Claus.

Unfortunately, Spotify **bleep** that up.


Merry Christmas and thanks for nothing Spotify🙁

I have canceled my premium account on January 15th.

I'm not in the mood to be ripped off by Spotify any longer
And still to pay for it

Unfortunately, it doesn't seem very likely that this will bother them, either. We've also stopped recommending Spotify to our customers because of this and considering that we've gone so long without so much as a rough deadline indicates, at least to us, that they aren't really interested in keeping the few of us (paying) customers that actually make an effort to spot problems on their platforms and to report those to them, and neither are they interested in following through with fixing these problems once they've been reported.

they don't even write here anymore.
absolutely ridiculous 🤐

Same issue here, worked well for some time and fails since updating Home Assistant some time ago (could be a coincidence)

If I open spotify app and play something on the echo and then restart spotify integration in home assistant it works again (for anywhere between 1 and 3 days) and fails again...

Makes spotify unusable for my automations 😞

Are there any workarounds on Home Assistant side that I could implement?


I installed Alexa Media Player addon, and you can do with it almost everything you do with Spotify addon.

 If you have any doubt on how to replace some specific command, let me know and I would try to help.

But that doesn't change the fact that Spotify is absolutely useless for home automation.

Hello Everyone,

Is tehre any update on this?

First i thought it was a openhab addon bug but after digging more into the functionality i've found out that the problem is leading to the id as name issue.

I've found out that issue also appears on the Echo Flex

I noticed that if I log out of Spotify everywhere and then log back in to Spotify, then only the echoes of the 4th generation are online.

So exactly the devices that normally go offline.

The Alexa skill is active, but only the 4th generation Echos are displayed in the device list.

If I deactivate the skill and activate it again immediately, all Echo devices are displayed.

Maybe this will help Spotify troubleshoot

It took a long time, but we believe this issue should finally be fixed. Can some help confirm?

I have checked it. To begin with all my echos were showing but the Echo
(4th gen) did not. I opened spotify. I played something through the echo
dot and it shows up correctly in my list of devices with no serial numbers.
So, it looks like you have resolved the issue. Thanks very much for looking
into it. I will keep you posted if anything changes.

the 4th generation echoes still disappear from the device list.

I'll just say that nothing has improved.

absolutely nothing.
not even a little bit

Hello. As far as the 3rd Generation issue with the serial number, it doesn't seem to be happening anymore, but I think it's still early to call.

I Haven't had the chance to run some tests with my 4th Generation, but based on recent comments, I think it's safe to assume that this issue with the 4th Generation Echo Dot suddenly "disappearing" has not been fixed and might be unrelated to our (now allegedly fixed) issue on the 3rd Generation.

I think most (if not all) users here have also faced this problem with the 4 Gen, and expect some kind of feedback on this end as well. I believe I don't speak exclusively for myself when I say that we hope you guys can also check into this issue.


Regardless, nice of you guys to keep us posted. Thanks!

I confirm that 4th generation are not yet visible in the device list. While the 3rd generation no longer shows serial numbers, but the real name of the device.



Unfortunately, I have to address you directly now.

When can users of the Amazon Echos of the 4th. Generation also use their devices with the API interface.???

the topic is almost 1 year old now.

we users paid money for their echoes.
The API middleware was not always free either.

the premium account also costs monthly.

Even if you don't give a damn about your customers, I still care about my customers.





Suggested posts