Help Wizard

Step 1


Get Item's Market param not working

Get Item's Market param not working

Get Item contains requests like "Get Playlist Items", "Get User's Saved Tracks", etc.

When I send a "Get Playlist Items" request with Market "from_token", the "restriction" part is returned as expected. For example, when I change the Market to US or some other markets, I won't get the correct response about restriction, the value in this response is still using the market from token, not the market I choose.


Here's a more detailed example:

The song spotify:track:2fQR507c0oIVWIyr7yX79D is available in PH (which is my token's market), and unavailable in US, but when I send the request, they both don't contain the "restriction" part.


Here's another example:

The song spotify:track:7EMwPovDSZ4De89VUcPnw9 is unavailable in PH and available in US, but when I send the request, they both contain 

"restrictions": {"reason": "market" }.


This request used to work (at least for the past year), and I found it not working properly today.

18 Replies

I am so glad to see your post. Now there are two of us. So, here is mine I post a month ago…

I had this problem too, but solved it. 


market & country were part of the previous version of the API.


They removed market because it was a bit redundant and kept country.


Hope that helps!

How did you solve it, I changed market to country but sadly still not woking.

Actually at the time your post been posted, the issue in my post did not exist.

This is my app ( It has a function of checking track's availability in a playlist. I'm sure that it's working in early March, and I found it not working yesterday.


The first picture is what I'm expecting (this screenshot was token in early March)

The second picture is what's happening now.


How did you solve this by using country instead of market? Can you share me with more info? Thanks a lot.

I noticed that the request works correctly if the value "from_token" is passed in the "market" parameter. Also, the response is correct if the track is not available in any country.


In other cases, the response is incorrect. 

I think I have encountered such a problem, but there is nothing I can do.

i have this problem too☹️ , pls fix it!! 

I also have this problem

still not woking

I also have the same issue and hope to fix it.

I have got this issue too, please fix it!

Still not working…

They way 'country' work is that every song has a list of countries in the songs attributes. Sometimes, you can end up with a PH song that is forbidden in US. In practice, the song will be greyed out in the US. For me, it doesn't make such a difference to leave it their greyed out. 


If you still really want to fix the problem, you can check each song's available_market in the response, then write some logic to decide to include or exclude.


Hope that helps!

@mashmia please don't try to help. You can’t.

 Your method is not correct, because does not use relinks.


And take a close look at the example in the Get Track section. The example also works incorrectly.

My code worked fine for 2 years, except for a couple of weeks when there was a similar bug. 

Same here. I'm the author of Skiley (, and the market parameter used to work for the last 5 years or so. However, in the last few months, only market=from_token makes any difference in endpoints accepting a market.

“I have got this issue too, please fix it!”

Is it fixed? Because now the "Get Artist's Albums" request ignores the market parameter! No matter which market I choose, only albums available in my country are being shown.

Suggested posts