Help Wizard

Step 1


Unable to create app in Spotify Developer

Unable to create app in Spotify Developer

I cannot create an app. I get an error message "Something went wrong, we were not able to create your app. Please try again later." I've tried multiple times over the course of the day and used several browsers. I've tried resetting my password and verifying my email. I need this to be resolved quickly as I am using Spotify Developer for an online JavaScript course.





United States of America


HP Pavilion

Operating System

Windows 10


30 Replies

I have the same issue. Tried to create app today with the same result.
I was doing it for Home Assistant 



I'm trying exactly the same (HomeAssistant) since Sunday, but get the same error.

Is there somewhere a official support channel to address this issue?

I have the same issue:/

Same issue.

I have the same issue 




I have the same issue

Same issue


How is this not fixed yet? 

I had to make another Spotify account because it looked like Spotify support didn't care to provide an actual solution. my new Spotify account works so it's something to do with my existing account. Looks like it's a widespread issue though.

Yeah, I've had this account for a decade. I refuse to create a new account when it is THEIR problem to fix, and they seem to be completely ignoring the issue. They give me the run around when I have contacted them. Terrible customer service altogether. 

I've poked people at support. They told me:

"There's indeed a thread there on this topic, and due to your inquiry here - I'll be able to flash it to relevant team. If you haven't posted there - please, post away, I'll do what I can from my side so this is seen from relevant eyes."

They only seem to know how to raise bills for consumers

Same happening to me. I think they are going to charge the usage soon.

Same issue here, has been for a month now...

I'm loving how this seems to creep every few weeks and then they all just ignore us.

Same here.

Came looking for a response, and see this goes back a few months and seems to be recurring... Guess I shouldn't get my hopes up on this being resolved soon.

Same here. Seems to be an authorization issue. In the web console I get a 401 error.

So possible issues:

1. Something is missing on our accounts that should be there (like the correct role) or permissions

2. Their API should allow our users to access it but it doesn't.


Anyway, hope it gets sorted out soon.

Do all of us in this thread have existing apps created? The only thing I can think of has to do with that. Because I created one no problem about a year ago, but the second one doesn't work. Either way though it should say somewhere if I can't make more than one instead of just throwing me errors

I just logged in with a new second account (where I didn't have another existing app) and it worked. But I was able to create a second app there as well. So it seems like it is a problem with some missing permissions on older accounts possibly? Not sure, but it was a good idea @Sidlulz

Suggested posts