Help Wizard

Step 1

NEXT STEP

How to stop recommendations

How to stop recommendations

I am vibing to Bad Religion and Anti-Flag and suddenly my playlist ends. Now this usually isn't a problem as recommendations are usually pretty good, but suddenly some Thousand Foot Crutch Christian music starts playing and ruins my whole vibe. I skip it but it comes back again. Now, there is a whole recommended mix for me that is called Christian Mix. On top of that, my current Daily Mix that I usually listen to has been plagued with not only Christian music but also German music and there is no avail. I have learned you can block artists, but new ones just keep popping up. I cannot see the end of the tunnel. While getting random German music recommended to me is kinda funny, I will literally spontaneously combust if I hear another Christian song. I am forced to question myself, what has lead me to this path. Was it because I listened to a podcast: The God Debate II because I supported the Atheist side? Was it because one of Bad Religion's songs is called American Jesus and I listen to that song on repeat? Please, Spotify, save me.

Reply
3 Replies

Hey there @Nebxlas , thanks for reaching out.

I know it can be a drag to deal with recommendations .

Firstly, you could turn off the Autoplay at the end of playlists(temporarily to deal with the suggestions).

 

Another step you've already mentioned, it's the "don't play this" feature. 

If you  can keep it up for a short while, things should start getting back to normal soon.

Basically, the more you play what you love, the better the recommendation's you'll get.

 

Lastly, I cannot get into specifics but your podcast activity will not affect your track suggestions.

I apologize for the inconvenience.

 

Take care.

 

 

 

TaylithSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

when i am playing my playlist, invariably every couple songs, spotify plays a recommended song.  how can i turn this feature off permanently?  i've turned off the autoplay, and looked in settings for every possible method to shut it off, but recommendations keep playing songs i don't want.  i just want to play my playlist and nothing else.  help!

 

Hi @1cleverly,

 

Thanks for the reply. Check if Smart Shuffle or Enhance are active, that will add recommended songs to playlists for you.

 

Hope this helps.

JoanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts