Help Wizard

Step 1


[Updated, new info] Playlists vanishing upon creation + Songs back on playlists after editing

[Updated, new info] Playlists vanishing upon creation + Songs back on playlists after editing


Premium (family plan)




iPad (7th generation), Macbook Air (early 2015), Fire HD 8 (6th generation)

Operating System

IOS 13.7, macOS Mojave


Hey there!

Since the new update, I've been having a lot of problems with playlist creation. Some of the playlists I make disappear upon making them, and I have not found a clear way to recover them.

A few days ago, I made 10+ playlists on the iPad, and when I went to move them into a folder on the Macbook, they all were 'ghost' playlists with blank titles. I could still move them around, but I couldn't open them or see what they were.

They haven't been disappearing from my library- They're still there, appearing fully in the library on the device they were made on (usually the iPad), but when I switch devices, they appear as a blank spot (on the MacBook) or just an untitled playlist with no icon (both the Amazon tablet and the iPad). 

When I try to open these 'ghost' playlists, or playlists that are clearly there, I get a message saying either 'playlist deleted 'playlist missing: this playlist is no longer valid'. Even further, I went to check the recover playlists option and none of the playlists were there at all.

Only a single playlist I made re-appeared after its disappearance, however I'm going to keep an eye on it just in case these problems continue.


Addressing the songs problem- Today I went through my 600+ song playlist on the iPad to root out the songs I didn't want. When I finished, all the songs were gone like they should've been. However, when I closed the app and went back to it, all of the songs I had removed were back. And they're still there. (This tells me that this is NOT a result of my account being accessed, as I removed 100+ songs and they all appeared in the same order they were when I removed them).


Restarting all devices and switching my password has not changed anything. Hope this can be fixed!

(screenshots attached for convinience)

10 Replies

Update: The playlist that came back is gone again. It doesn’t appear on my computer, and this time it says it was deleted.

Going to the recover playlists page is no help, it does not appear there either. 

(I am unable to provide screenshots right now as the site doesn’t seem to support jpegs, and it’s a whole process to change the file type)


The songs that came back are still there as well, and are in the same places as before. Once again, my password has been changed and nobody’s been accessing my account.

Hey there @Stormybluejay


Thanks for reaching out about this here in the Community. 


Just to make sure, could you see all the new playlists (with all the songs) only on your iPad in which you created them?


Additionally, would you mind checking if you create new playlists on your other devices (PC, phone) the same happens or this issue is only happening when you create playlists/remove songs on your iPad?


If you notice that this issue is only happening on your iPad, we suggest that you perform a clean reinstall on it following these specific steps.


If this doesn't make any difference, we suggest that you check if the OS of your device has any pending updates. 


Keep us posted on how it goes 🙂

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Hi there! Thanks for the response, I’m going to try all of this and see how it goes.

In regards to your question about the iPad playlists, occasionally I can view the playlists I’ve recently made in their entirety across all my devices. I have created playlists on the MacBook as well, though, and those also showed up as ‘missing’ or “deleted” on other devices.

In addition, after creation on a specific device itself it also vanishes or gets ‘deleted’ on the device in which it was created on. It’s happened both on the MacBook and the iPad.

For example, I created a few playlists on my iPad, and again went to sort them on the MacBook, to find that they either weren’t showing up or were showing up without titles. Again, I could still pick them up and move them, but I couldn’t open or edit them. 
When I switched back to the iPad they had either disappeared entirely or were having the same issue- I couldn’t open them or edit them, either, and got the error message mentioned above when I tried. 

Also, about the songs- it’s happened both on the iPad and the computer. The first time it happened I was using the iPad, and all the songs came back, and the second time I tried the computer, just in case anything changed. It did help, but about a third of the songs came back. I removed the ones that did come back and so far everything’s been okay.


That said- I am going to try the solutions you proposed, and I'll keep you updated on what they do!

Hey @Stormybluejay,


Thanks for keeping in touch and for the extra info.


That's very odd. When you have the chance, give the steps in the link @Eni shared above a go to see if a clean reinstall solves this.


We'd also like you to try using a different Internet connection, like another WiFi network or a mobile hotspot, to see if that makes any difference.


We'll keep an eye out for your reply.

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

Hello! Thank you for the response as well.


I have gone ahead and updated my iPad, it did have an update waiting and I am now using iPadOS 14.5.1. It hasn’t changed anything with existing playlists, however I have created a test playlist to see if anything happens (currently I don’t have access to my computer because I am out of the house, but I will provide an update to tell you both if it transfers to the computer or not).


I will go ahead and proceed with the clean reinstall, and I’ll see if it changes anything with the existing playlists as well as the new one.


Edit: I forgot to mention that I did a normal reinstall after I updated, as I neglected to do that prior to commenting here. It also didn’t do anything, just wanted to mention that I did do it. I’m going to go do the clean reinstall right now, I’ll keep you guys updated!

Hi @Stormybluejay,


Thanks for your quick reply.


We always recommend a clean reinstall as it's more thorough than a regular one and can be helpful to get rid of any cached/corrupted files that might cause trouble.


We'll be waiting for your reply after you've tried that and a different connection to see how it goes 🙂

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

Update: I’ve completed the clean reinstall! And throughout this whole process I have switched WiFi connections, I am using someone else’s WiFi at the moment and not my home WiFi. 

The clean reinstall unfortunately did not recover the playlists I had lost (thankfully they only had a few songs each, though there were many). But the test playlist is still okay, it is unchanged as of right now.


I’ll still continue to post updates if anything changes!

Hey @Stormybluejay


Thanks for keeping us posted. 


Just to confirm, do you still experience the issue once connected to a different network? If not, we recommend troubleshooting your original connection, for example by restarting your router. It's also a good idea to contact the Internet service provider so they can take a look on their end as well. 


We also suggest checking out the steps in this support article on how you can recover your playlists. 


Keep us in the loop here. 

Hello, thanks for the reply!


Yes, I did experience it on different networks, I went to a friend’s house and connected to her wifi as well, same troubles were happening.


I also have gone to try and recover my playlists, however none of them show up in the recover playlists section (the most recent one listed there is dated to be in early may, if I remember correctly, and I absolutely remember deleting that one).

In other updates, none of the playlists have come back yet (which isn’t too much of a problem, they were very small playlists mostly). Nothing has yet happened to my testing playlist, however I am experiencing issues with a playlist I created last night.

Last night I added about 198 episodes of a podcast onto a playlist for more convenient listening, this way none of the bonus content would show up if I wanted to re-listen to just the podcast itself.

But, as I was going to listen to it this morning, the playlist had gone. This time, it’s gone without a trace, not in my library on any device, not in recover playlists, and it doesn’t appear as an invisible playlist, either.


It took ages to put together, unfortunately, as when I went to add an episode onto the list, the ‘add to playlist’ button was completely missing and blank, and when I clicked it, it would do nothing.

It turned out I had to wait for it to load for it to do anything, and it took a hot minute to load.


Sorry, that was a bit of a ramble, but I’m in a rush so I don’t have much time to edit ^^

Hi there @Stormybluejay,

Thank you for your reply and confirmation. We really appreciate the troubleshooting you've done so far.


Can you log in with another account - such as a friend's or a family member's and see if you get the same behavior from their account? This will help us understand if it's account related.


We'll keep an eye out for your reply.


Take care!

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Suggested posts