App not opening

App not opening

Hi, I have a Spotify premium account and for some reason Spotify stopped working. I'm trying to open the iOS app but for some reason it won't open, it just looks that it is going to open but immediately closes all by itself.


Do you know what might be causing the problem? Everything was working perfectly before. I already tried reinstalling the app but nothing...


Thank you.

3 Replies

Hi I have the same problem. I had basic version and today it just didnt open. I only got a message about some -1712 error. I tried to uninstall and install again and nothing. I purchased the premium version and it's all the same. What did u do?


Hi 🙂


Is your iOS up to date (6.0.3)? Your phones memory could be full. Or it could have run out of RAM (Random Access Memory, what everything uses to launch applications), make sure to close all the apps in your multitasking bar before you open it.

Try force rebooting your phone (hold home and power button for approximately 10 seconds, then wait, if apple logo doesn't appear turn it on like you would normally).


If worst comes to the worst, you could run a full backup onto your computer (backs up applications (and data in them), settings, contacts etc. basically everything), run a factory reset, and setup your phone from the backup you created (It will be exactly the same, even conversations are saved, but the error may be fixed).


Have you jailbroken your iOS device? This can sometimes cause problems with applications especially if you downloaded a malicious app, or you enabled SSH and someone hacked your phone.


It would be helpful if you filled out the  iOS troubleshooting guide template




Let me know how this goes, and if you fill out the template please make sure to post it to help identify the problem, thanks!

This post was by Taylor - I do not work for Spotify!
If this solved your issue - Mark it as a solution! If you like my post - Please add Kudos!
||  Spotify Profile - Taylor   |  Feel free to PM me - Here  ||

Hi! Thanks very much for such exhaustive help! But I have macbook and Im speaking about the application on my laptop, not in iphone... I suppose that makes a difference, no? I dont know what's the problem, since yesterday night all was working perfectly and today in the morning I couldn't open the application...



!! I've already found all the answers I needed!  🙂 I was just looking in the wrong place before... 😉 Thanks anyway for help!

Suggested posts