Announcements

Radio not working over 4G/LTE...Fine when connected to wifi.

Reply
Highlighted

Radio not working over 4G/LTE...Fine when connected to wifi.

Newbie

Weird bug in the Spotify app for iOS. The radio feature doesn't work at all when connected to 4G, but it'll appear when connected to wifi. This problem has been going on for the past couple months. I had been waiting for an update to address this issue, but so far nothing. I was wondering if anyone else has dealt with this issue and if there's a fix. I tried deleting the app, resseting my phone, and reinstalling it, but I'm still running into this issue. Everything else is working as it should, but if I'm paying for a subscription, everything should be functional. By the way, I'm using an iPhone 5 running version 6.0.2 & the most recent version of the Spotify iOS app.

 

Over 4G.

 

IMG_6832.png

 

Over Wifi

 

IMG_6675.png

6 Replies
Highlighted

Re: Radio not working over 4G/LTE...Fine when connected to wifi.

Casual Listener

Hi,

 

same issue in Switzerland!! Funny is that one of my friends can use it (same iPhone 5, OS and Spotify version)...

 

any ideas?

 

Cheers

 

Highlighted

Re: Radio not working over 4G/LTE...Fine when connected to wifi.

Spotify
Spotify
Hi guys,

The app doesn't support 4G just yet, which may explain why you're running into problems. Is it still working nicely through WiFi?
-------

Check out how we're doing over @SpotifyStatus

Question answered? Just click 'Accept as solution' to help other users out. Easy.

Who's your Spotify Star?
Highlighted

Re: Radio not working over 4G/LTE...Fine when connected to wifi.

Casual Listener

Thanks Sam,

 

yes WIFI works fine - streaming over 4G works also fine (e.g. What's New).

 

However radio over 4G works for my friend (exactly the same setup in terms of iPhone version, OS and Spotity).

 

So you guys will solve this issue?

 

Cheers

 

 

Highlighted

Re: Radio not working over 4G/LTE...Fine when connected to wifi.

Newbie
Did anyone solve this? I'm having the exact same issue.
Highlighted

Re: Radio not working over 4G/LTE...Fine when connected to wifi.

Newbie

I'm having the same problem. 

 

Radio works just fine on a WiFi connection, but if I'm on 3G/4G it won't work.  Either the screen is blank or it shows the stations but remains loading all the time.

 

The weird thing is that sometimes (really few ocasions) it works

 

I've already uninstalled and reinstalled the app and the problem remains

 

The most interesting thing is that on a cheap Alcatel Android phone with the same mobile operator works fine and if I set the WiFi router on the android phone and I connect the iPhone to it, it works

 

It looks like the problem on the iPhone appears when you are on the mobile network

 

 I'm using an iPhone 5 running version 6.0.2 & the most recent version of the Spotify iOS app.

Highlighted

Re: Radio not working over 4G/LTE...Fine when connected to wifi.

Newbie

Same issue in Australia on Android.

SUGGESTED POSTS