Announcements

Help Wizard

Step 1

NEXT STEP

Spotify app not working on IOS 17.4.1 IPhone

Spotify app not working on IOS 17.4.1 IPhone

Plan

Free

Device

(iPhone 11 Pro)

Operating System

(iOS 17.4.1)

 

My Question or Issue

Hey there, I have recently unsubscribed from Spotify Premium after a few years, and I have updated my IOS to the latest version a few weeks back, but I am unsure this is related to that at all. 

The Spotify app seemed to be ok at first, but has stopped working since a week or so. It seems like it works ok on the browser version on my desktop machine, but it doesn't work at all on the IPhone. I have already uninstalled the app, installed it again, reset my password and logged out/back in, rebooted my phone. There are no updates apparently so all is running the latest available version.

With "not working" I mean that I cannot see the songs on the interface, all I can see is the artist, podcast don't preview the episodes, and nothing plays even if I try to click the "play" button. Basically it's useless and everything is grayed out...

Any help would be greatly appreciated.

 

Thanks!

 

Reply
2 Replies

Hey there @lindalasagna

 

Welcome to the Community and thank you for the question. 

 

Having removed your subscription should not in any way impact your experience of using Spotify the way you have described in your post, so let's take a look together!

You mentioned that Spotify on your desktop does not behave in the same way, that narrows things down to your mobile device and how it uses the app.

Have you tried seeing if this happens on another IOS mobile device, you could ask a friend or relative to test with your account and see if the same thing happens there as well. 

 

Lets try clearing your cached files, sometimes leftover cache can impact the way the app works even after a soft reset. Check this article out for more help on how to clear cache. 

 

Hope this helps out, keep us posted 

MartinModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Hi Martin,

 

I had tried already asking some friends to test on their end, as well as clearing the cache...

That didn't work but suddenly yesterday the mobile app started working again, so maybe it was really a bug or something like that (I work with computers and I am my ITs and TDs worse nightmare as I am that person that finds all the bugs all the time lol).
Thanks so much anyway 🙂 

 

Best,

L

 

Suggested posts