Announcements

Spotify connect problems after lots of troubleshooting

Spotify connect problems after lots of troubleshooting

 

 

Plan

Premium Family

Country

Ireland

Device

iPhone 12 Pro, android tablet, sonos

Operating System

iOS 14.4

 

My Question or Issue

I have a sonos S1 system which comprises 5 older connect amps connected to ceiling speakers, one newer Sonos amplifier and one Sonos One. I also have multiple amazon echos and I have 2 Sky Q boxes. All are on the same enterprise level network and all the Sonos equipment is on wired Cat6, not wireless.

 

In the Spotify app, when I select devices, I cannot see any of the Sonos speakers or amps. I see all off the echo devices no problem and I see the 2 sky boxes. My Spotify account is linked in the Sonos S1 app and I can play Spotify no problem through the Sonos S1 app (albeit with the usual limited functionality). If I start Spotify through the Sonos app and then launch Spotify app from within the Sonos app, the Spotify app does not see that I'm using Sonos as a device and the device menu does not detect the Sonos system, despite the fact that the music is streaming though the sonos speakers. Under Airplay, I can use the 2 airplay compatible devices but none of the others.

 

I have unlinked everything, uninstalled Sonos and Spotify apps, restarted the iPhone, restarted all the sonos equipment, logged out of accounts and logged back in again to no avail. I've checked all the necessary network settings link mDNS, IGMP snooping, STP etc and restarted the entire network. 

 

These issues also occur on an older android tablet that I also occasionally use. 

 

This is going on for a few weeks. Previously it had worked ok with the same identical setup. Yesterday I made a chance discovery when I asked one of my echo dots to play music in a particular room. ('Alexa, play XXX in XXX"). The music played through the sonos speakers in that particular room as expected and when I then opened the Spotify app, that particular room's Sonos speakers appeared in the device list! I did it for a few other rooms an the same thing happened. 

 

It appears that the Spotify app cannot find the Sonos speakers on the network, but Alexa can and that somehow allows the Sonos app to see them. 

 

It's a real pain not being able to use the Spotify app to control the sonos speakers. 

 

Any suggestions?

 

Thanks

 

Reply
15 Replies

I have just raised a similar issue and also using Sonos S1. I can see all the zones from the Sonos App and also Spotify on a windows 10 pc so this looks like a IOS issue.

I have just upgraded to Sonos S2 and this has made no difference to the problem of not seeing Zones

Solved my similar issue, was firmware on UniFi AC pro access point

Hey there @ronanryan

 

Thanks for reaching out about this in the Community, and welcome 🙂 

 

We'd first recommend making sure that your Sonos device is fully up to date. 

 

You can also perform a clean reinstall of both apps. You'll find the steps for the Spotify app here. This is more thorough than a regular one and can be helpful for clearing any corrupted files that might be causing issues. 

 

Let us know how it goes. 

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi

Thanks for the suggestion. I did the detailed clean uninstall as you suggested but it made no difference, It still doesn't work. My Sonos system is fully up to date.

Can you escalate this further please?

Hi @ronanryan

 

Thanks for getting back to us. 

 

Have you checked that the Spotify app has all permissions enabled in your device's settings?

 

Also, make sure that all devices are connected to the same network. 

 

Keep us posted.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Yes. All are enabled. When I first launch it, I can't see other LAN devices (eg sky Q boxes) until I allow that permission. Sonos does not appear unfortunately

Hi again @ronanryan

 

Thanks for your reply and the info. 

 

Just to confirm, have you checked that ‘Control Sonos from Spotify’ is enabled in the Sonos app?

 

This will only show up in Settings if it is not yet enabled. 

 

We'll keep an eye out for your reply. 

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

That is enabled (not visible).

Have you tried Sonos and Spotify apps on Windows (Wi-fi and Hardwired)  to see if a IOS or Network problem

I tried that and the windows app is no different. It can connect to all the echo devices, the sky boxes and even an iMac running Spotify but it cannot see any of the Sonos devices. I have also tried MacOS and Android and none of them work.

This seems to be a common issue:
https://www.reddit.com/r/sonos/comments/j5lub3/issues_with_spotify_connect/

Reddit users suggest Apple Music as an alternative.

Hey @ronanryan,

 

Thanks for keeping us in the loop. 

 

Next thing you can check is if all your devices are supported for Spotify Connect. Check out Spotify Everywhere for compatible devices. If you don’t see yours there, you can check with the manufacturer. 

 

It's also a good idea to make sure that all devices' firmware version is up-to-date. If you're not sure how to check this, get in touch with your devices' manufacturers for how to update the version software. 

 

Hope this helps. Let us know if you have any questions.  

Hi Ivan

Your comment was really of no additional value.

My devices are supported and they are fully up to date, as I stated in the description of the problem.

I'm paying €15 per month for premium family service and I cannot get support. Most of the suggestions I get from spotify support are tasks that I have already completed and you've tried to offload responsibility for this to Sonos. Whay can you not fix it?


 

Have you got a way of testing a zone off the main Network? Sonos and Spotify work or there would be many posts so I keep feeling your issue like mine was is Environmental. Has it ever worked or is it new installation?

Hey @ronanryan

 

Thanks for getting back to us.

 

We need you to try the steps we mentioned in order to better understand what's happening there on your end. Then we’ll be able to advise you further. 

 

That's why we'll need you to let us know how it goes after performing a factory reset of all the devices.  

 

Could you also let us know if you see any difference after setting your iPhone as a hotspot? Check out this help page on how to do that.  

 

It’d be useful if you list all affected devices and their exact OS? This will help us take a closer look. 

 

Looking forward to your reply. Enjoy your day!

Suggested posts