Announcements

Help Wizard

Step 1

NEXT STEP

Spotify disconnecting from playing on Sonos Play 3

Spotify disconnecting from playing on Sonos Play 3

Plan

Premium

Country

UK

 

Device

(iPhone 12, Sonos Play:3)

Operating System

(iOS 16.1.1)

 

My Question or Issue

I have Sonos Play 3. Spotify from either Spotify app or Sonos app will cut out/disconnect after around 5-10mins and then not re-connect. This does not happen with other streaming apps such as Apple Music or BBC Sounds. Interestingly I don't have this problem with my Sonos Beam. I have tried all the usual debugging tips such as hard reset, disabling all other DHCP servers in my network, updating SW etc. etc. but nothing seems to help? Any advice welcome

 

Reply
12 Replies

Hey @nnjackson

 

Thanks for reaching out about this here in the Community. 

 

First up, we suggest that you try logging out and then logging back in to see if that makes the difference. 

 

If the issue persists, It's well worth running a clean reinstall of the app by following these specific steps. 

 

If that doesn't do the trick either, you can try unlinking and relinking your Spotify and Sonos accounts by following the steps here

 

Let us know how it goes.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

I have done all these steps several times and issues persist.
This only happens with Spotify on Sonos…all other streaming platforms have no issues

Trying to avoid embarrassment at dinner tomorrow.

Hey @nnjackson

 

Thanks for your reply. 

 

Would you mind checking if the same happens while using a different internet connection? You can try creating a hotspot on your phone and using that to test this. 

 

On another note, we'd like to know if this started happening after a specific event such as an update. 

 

We'll be on the lookout.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

In the meantime, I have purchased a Sonos Beam and the issue is restricted to the Play 3. The Beam works without issue

Hey @nnjackson,

 

Thanks for letting us know.

 

Were you able to test this out using a different internet connection (preferably by a different provider)?

 

Let us know how that went.

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Yes. No difference

Hey @nnjackson,

 

Thanks for the reply.

 

Does the described behavior persist if you use a different phone?

 

On that note, are you giving the voice command to the Sonos and start Spotify like this?

 

Keep us posted,

 

Cheers!

DianModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Same behaviour on all phones. I don’t use voice commands.

Hey @nnjackson,

 

Thanks for getting back to us! 

 

We'd recommend to try a factory reset on the Sonos device. Then you can relink your Spotify and Sonos accounts again and test if the issue still persists.

 

On another note, you mentioned that you're not using voice commands, but we believe it might also be a good idea to try starting a playback via command to test if the same behavior will occur.

 

Let us know how it goes. 

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

I have the same problem? 
any other solutions ?

Hi…I never resolved the issue. Kept being bounced between Sonos and Spotify. Neither organisation accepting responsibility or satisfactory advice. In the end I sold the Sonos 3.

Suggested posts