Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

context menu missing

context menu missing

WHY is there Still no context menu in the search results when i keep my finger on a track??????????!!!!!!!!!!
Reply
10 Replies

I've just upgraded to the latest version of spotify this morning (running iphone 4, ios 5.1.1), it says there is meant to be a new context menu when you tap and hold on a track, but nothing appears when I try it?

 

Any ideas?

I just tried it on my iPad 2. When you have an album pop in from the right of the screen, the tracks show below the album cover. Those tracks you can long-press to get a context menu.

 

So it is " any track", just currently not "anywhere in the Interface."

Community Ergo Sum

This is really irritating me as well. And i think both me and luebbi is talking about the iphone version, right? 

I que tracks all the time, so that context menu in the search results is pretty important to me.

I'm going to need to get more phones.

 

Had a look on a colleague's iPhone. It looks like swiping on the iPhone gives the same options as long press on the iPad.

Community Ergo Sum

Sure that it's the latest version and on the SEARCH tab? I've tried reinstalling already. Long press doesn't work for me, neither does swipe. In playlists though, swiping works.

I'm very sure that you seem to be right that there currently is no long-press functionality in the search section. Neither on the iPhone, nor the iPad.

 

I had hoped to make you feel all warm and fuzzy inside, but I seem to have failed miserably.

 

Let me go and find someone I can ask about this; if anything, to see if I can provide you with more clarity.

 

I'll be back.

Community Ergo Sum

Your help is much appreciated, the app is absolutely usable despite this but it is pretty annoying so a hotfix would be sweet.

So..the word is that the long-press option is iPad-only. The swiping action on iPhone is a little bit, shall we say, quirky right now.

 

Good news is the right folks here are aware; and here are some suggestions for temporary workarounds:

If, when searching for tracks, the context menu doesn't show up by swiping tracks, go into the album search and then back to tracks; it should show up now.

Alternatively, navigate to another view, away from search, then back and try to swipe again.

 

If you can't get any of that to give you results, please post back here and I'll add your info.

 

Things like phone model, iOS and Spotify version are always helpful.

Community Ergo Sum

Switching to album view back to songs did it for me, awesome. 

Using iphone 4 16 gb, ios version 5.1.1 and spotify version 0.5.2

thanks for your help 🙂 i hope this will be fixed soon. for me searching and adding tracks to playlists is the most important function. can't see how this could happen

Suggested posts