Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Cannot play Spotify on Echo Dot due explicit filter

Cannot play Spotify on Echo Dot due explicit filter

I linked my Spotify account to my Amazon’s Echo Dot and everything was working OK, but from few days on, when I ask Alexa to play music from Spotify Alexa responsable “I cannot play music because the explicit filter is activated” which is not.

If I select Echo Dot from available devices, the explicit option is gray and I cannot turn it off.

If I ask Alexa to play music from Amazon Music, I don’t have issues.


12 Replies

Hey @ppquintal Welcome to the Spotify Community!


What i would recommend is checking whether your explicit content is enabled on your Alexa App. Sometimes it could turn on out of the blue.


Happy New Year!


I’ve tried disabling the explicit filter in Alexa but I don’t have the option enabled. I also tried using the voice command but I doesn’t work.


Have you checked to see if the filter is active on Spotify? To check this you can go to Spotify App > Your Library > Go to Settings > Explicit Content > then Allow Explicit Content.



I did everything like you say, but it didn’t work. What Amazon told me is that I cannot use Spotify in my Echo Dot because my IP address is from Mexico and in this moment this feature is not available for Mexico customers.

I was shocked.

Right... Well sorry i couldnt help you out, but its great to know this information.


Happy New Year!

This could be an Amazon issue go to your Alexa app and check your search settings the two could be conflicting with each other meaning Spotify is allowing explicit content but Alexa is not I hope this helps you and best of luck

I have the same problem.  II hav a feeling it's an Amazon issue as well.  I'm in Canada and we do not have the explicit filter option available to us either. Somehow it believe it became active on my Amazon account and I have no way to turn it off or disable it. I have now spent over an hour on 2 occasions with Amazon support who cannot figure it out. I mean, can they not go into my account and see if I have it turned on and turn it off?  They are now blaming Spotify.


I even attempted to switch my country to the US to see if the options became available to try and disable it but I need a US credit card to do so. Very frustrating. I'm going to add some additional music services to see if it blocks those too. Best of luck.

Hi. I am having exactly this issue and it started a couple of days ago.


I have turned off explicit filter on the Sonos Alexa and on the Spotify account but just asking for Britney spears/Little mix and any other music with no explicit content fails to play.


Alexa replies "I cannot play this with the explicit filter on". It is not on!


Guessing this is an Alexa/Spotify integration issue that has just happened as it was fine for the past 3-4 years!


It is the same for 3 of 4 of our accounts linked to Echo dots and a Sonos speaker. The 1 Echo dot plays ok that has never had the filter on.


Please help!

Same issue, really seems there are many issues with Spotify and Joe Rogan Experience. They should fix or discover which devs on their team are so WOKE that they have taken such effort to impede on freedom of speech. Fire them.

Same here.

Issue is now fixed for me but don't know how?

I put a ticket in with Amazon so they may have pushed it? 

Either way, 2 happy kids now.



Suggested posts