Help Wizard

Step 1


Android 11 Media player controls missing

Android 11 Media player controls missing







Google Pixel 3a

Operating System

Android 11


My Question or Issue

The Android 11 update added a new media player control section to the quick settings menu when you swipe down from the top of the screen.  My phone does not show the music control panel for spotify.  It will work for other apps like google podcasts, but not for spotify.  Is this feature simply not supported by spotify yet, or is there an issue causing it to break?  I have not seen anyone else complaining of this issue in the past hour or so of searching the internet, so it must not be prevalent if it exists.  It's driving me bonkers because now I have no way of controlling my music without opening the app, music controls also do not show on the lock screen as they are supposed to. 


Edit: I did a content wipe and reset my phone, then restored from backup. I also uninstalled and reinstalled the spotify app multiple times, on the third time it fixed the issue. Hope this works for anyone else who is having the issue.

7 Replies

I am also having this issue on my Google Pixel 4XL on android 11. The media controls work for all other media apps (like google podcasts), but not spotify.

I have the same problem on a Pixel 4A


Also having issues when the track doesn't update whilst in the app.


And issues when connected to a Bluetooth speaker... Although this only happens when the phone is locked. Oddly enough it also happens with YouTube, so might be an OS issue.

I have a friend who is having issues with bluetooth as well, it must be as OS issue. As for spotify, I think reinstalling the app a couple times is what fixed it for me. I also did a factory reset for my phone, but still had issues until I reinstalled spotify.

I reinstalled the app multiple times and it fixed it.

Hey everyone,


Thanks for getting in touch with us 🙂


@TwistedSync Glad to hear it worked out and everything is running smoothly.


@gnguralnick and @electrocutus We'd suggest you check your settings. That could be the reason for the media controls not working.


@Evolution_Man We are aware that the app behaves differently after the Android 11 update and we are looking into it. You can head here and add your +Vote and Subscribe to the thread. That way you can stay up-to-date with any relevant news about this.


If you have questions, don't hesitate to reach out to us. We'll be happy to help.






Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I read in another thread that it might be a matter of the notifications settings for the app. I checked mine and that solved it. I have a Pixel 6.

Suggested posts