Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Android app glitches out randomly

Android app glitches out randomly


Premium Student




Samsung Galaxy Note 10+

Operating System

Android 10


My Question or Issue

Unfortunately, there isn't really a pattern for this issue. It happened three times in the last 5 or so hours though with heavy usage (around 3 hours of music being played out of the 5). When I'm playing a song and I expand the player screen (with the cover art, play/pause, back/next, like button, etc.) the scrub bar doesn't move even when music is playing, the play/pause button sometimes shows play while music is still playing (so I have to tap twice to actually pause music), and the actual music playing doesn't match up with what's coming out. When I minimize the player screen so it just shows as a bar at the bottom, the play/pause button doesn't work at all. The actual music playing still does not correspond to the cover art and title being shown. The only way for me to fix this is to reinstall the app, but the problem comes back after a few hours. There are no available updates for either the phone or Spotify. I don't think this changes anything, but I'm using Galaxy Buds to play/pause music and I have the Spotify watch app installed on my Galaxy Watch, but I don't use that app very much.

3 Replies

Hey there @CloudBurst


Thanks for reaching out to us about this - we'll be glad to help you out here.

Just to confirm, have you tried a clean reinstall instead of the regular reinstall? Make sure you perform it on both devices.


We recommend this step as it'll remove the old drivers first and then install the new ones. These changes tend to solve issues like the one you're experiencing.


Hope this helps. Let us know how it goes. 

I am experiencing a similar issue.  It seems to be tied to my Galaxy Watch connection.  It works fine for a while and them starts glitching out liked this user describes.  It also loses the ability to display the notification and lockscreen controls.  I have tried everything to fix it including the clean install.  I have wiped data, reinstalled, wiped data associated with the Watch.  I fix it by force stopping the app and it will work fine again for a while.

try to remove the application from the watch, it seems that solves the problem

Suggested posts