Announcements

Can't disable shuffle play in Daily Mix

Solved!

Can't disable shuffle play in Daily Mix

Plan

Premium

Country

Poland

Device

Samsung Galaxy S7

Operating System

Android Oreo

 

My Question or Issue

Go to "Liked songs" section, click "shuffle & play", now go to any "Daily Mix" and play it - songs will play in random order and you can't disable it unless you go back to "Liked songs" section.

 

Reply

Accepted Solutions
Marked as solution

Hey @n3hrox,

 

Thanks for getting back to us and confirming that.

 

The shuffle button in Daily Mix doesn't appear in the Now Playing View by design. You can access it by tapping the three-dot menu in the top-right corner - it's on the top row of buttons along with Repeat and Go to Queue.

 

Hope that clears things up! Let us know if there's anything else 🙂

View solution in original post

6 Replies

Hey there @n3hrox

 

Thanks for searching for the answer you need here! 
 

In case you get stuck on the Shuffle Play feature and it's not possible for you to disable it we'd recommend first performing a clean (more thorough) reinstall of the app on your Samsung-device to make sure you get the latest app version with all updated functionalities. Check out this help page in order to find the steps for clean reinstall depending on the affected device. 

 

If that doesn't help with disabling the random shuffling, check if any power saving or data cleaning settings or apps are activated for your mobile device. You can also try authorizing Spotify to run without restrictions despite the mentioned settings being enabled. Make sure you try these steps since such features can often prevent the app from operating at full capacity, leading to your playback preferences not being applied.

 

Hope this helps. Let us know how it goes. 

This is completely not what I meant. I can turn on and off shuffle without any issues, the problem is that if you enable shuffle inside "Liked songs" and go to "Daily Mix" it still shuffles songs, whereas it should behave like a radio. And the only way to disable shuffle inside "Daily Mix" is to go back to "Liked songs" and disable it there. So in my opinion it is either:
a) bug - shuffling songs where it shouldn't happen
b) missing feature - lack of shuffle button inside "Daily Mix"

Marked as solution

Hey @n3hrox,

 

Thanks for getting back to us and confirming that.

 

The shuffle button in Daily Mix doesn't appear in the Now Playing View by design. You can access it by tapping the three-dot menu in the top-right corner - it's on the top row of buttons along with Repeat and Go to Queue.

 

Hope that clears things up! Let us know if there's anything else 🙂

After tapping three-dot menu in Daily Mix this is what I get (please see attachement). It's in Polish so from top to bottom:
1. Watch
2. Download

3. Turn on playlist's radio

4. Find in playlist

5.  Sort playlist

6. Share

7. Add to main screen

Am I missing something here? Spotify Android version 8.5.60.1013, newest that shows up for me in Google Play Store

options_menu.png

nvm, I found the place you meant. I still find it a terrible design choice but whatever

Absolutely horrendous design. At this point, might as well consider this a bug or missing feature.

Suggested posts