Google Assistant specific song


Google Assistant specific song

Google Assistant understands my song requests (via voice command) and even repeats the song name back to me along with adding the artists name and "Playing on Spotify". See attached screenshot for an example. But Spotify doesn't actually start playing anything.


To clarify, if I ask the assistant it to play an artist, a playlist or even just "play something", Spotify starts playing my request just fine. The problem is when you ask for specific songs and nothing plays. I'm sure the "Assistant side" works fine but the "Spotify side" doesn't follow/receive this type of instruction correctly.


I am using a phone - Pixel 2 XL and have not tried this on any other devices as of yet (but have ordered a Google Home and will be testing it on that when it arrives).


Just to note I have updated Spotify to the latest version along with Android and Google app, but still no joy. I generally keep everything up to date anyway.


I have uninstalled and reinstalled the Spotify app, too, but again no luck.




Accepted Solutions
Marked as solution

Yeah, it's definitely working again. Since yesterday or something.


View solution in original post

9 Replies

Same problem on the OnePlus 3. Spotify and Google on the newest version (even Beta for Google app). There is a similar topic ( but even though it is marked as solved, there is no solution (they only mentioned, that they got a support ticket).

Ha, my Mate 10 started acting up the same way a few days ago. 


It always worked before. 


But now it says "okay playing on Spotify" it takes a while, spotifS opens but nothing happens.


Please fix it, I use this feature a lot while driving.

For me, a week or two ago it was still working. Tried to mess with spotify/google assistant settings but nothing changed. Dont know, what has changed since then. My main purpose is driving as well.

I've tried: 


- Unlinking Spotify account


- Formating cache partition


- Uninstalling spotifS


- Clearing the Google App data



After I conoletlco reset the phone to a factory reset, it worked for a while but then some updates were installed and it stopped working again.


It's only when asking a specific song/artist/album


If I say "play music"  it will start 

And the commands to skip music and repeat last song works. 

I use this a lot whilst driving, too, so it's even more frustrating when you can't get to distracted from concentrating on driving.

Can confirm it's working for me now. Can anyone else confirm and shall conclude this ticket?

Marked as solution

Yeah, it's definitely working again. Since yesterday or something.


Yeeeees i think, they fixed it! Finally.

Same issue here. Very frustrating, as things work perfectly in Google Home. Just switched from Apple iphone 7 to a Pixel 2 XL. My kids are mocking me as this thing does not work properly... They are sticking with Apple...


The issue happens only when Spotify is already opened. If I close the app and order a song, then it works fine...

Suggested posts