Help Wizard

Step 1


Google clock uses standard beeping instead of spotiy

Google clock uses standard beeping instead of spotiy






BlackBerry DTEK50

Operating System

Android Marshmallow


My Question or Issue

Some weeks prior to now my Google Clock App started using the standard sound for an alarm in stead of the chosen playlist.

It still shows the playlist as the current choice, but when the alarm should go off, I see only the notification without the sound and after several seconds the standard beeping noise plays.

I tried other playlists and songs. They don't work. 

I tried un- and reinstall both apps. Still doesn't work. 

I tried it with and without battery optimization. Still not solved.

No clue. No error message. No music. All frustration.


I hope this can be fixed. 

3 Replies

Hey there @Blaubartbube,


Thanks for reaching out to the Community.


We suggest following these steps:


1. On the Google Clock app, select Hide Spotify on the 3 dots menu after going to Alarm sound.

2. Log out from your Spotify account, restart your device, and log back in.

3. Open the Google Clock app, select Show Spotify on the same menu, and select your desired song/playlist.


If this doesn't do the trick, we recommend running a clean reinstall of the Spotify app by following these steps. This can be helpful to get rid of any cached files that might be causing trouble.


If the issue persists, can you let us know the Spotify version you're running, and if the same happens in any other device?


We'll be looking out for your reply.

Mario Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Thank you for replying so fast. I've tried the possible solutions. Sadly this didn't change anything. 

I don't have other mobile devices so I can not know if the same would happen on others.

I am using spotify version


Hey there @Blaubartbube,

Thank you for your reply and confirmation.


Just to confirm - are you connected to to Wifi or data when the alarm starts?


Also - do you try to play through external speaker (i.e. Chromecast, Google Home, Amazon Echo) on bluetooth?


Can you try to log in with another account - such as a friend's or a family member's to see if the issue persist?


We'll keep an eye out for your reply.



Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Suggested posts