Announcements

Help Wizard

Step 1

NEXT STEP

Local songs cannot be played on my android phone

Local songs cannot be played on my android phone

Hello I've imported some songs into Spotify Premium on windows and I added it to my playlist. I can play the playlist on my computer but on my phone, I tried downloading the playlist but it still appears gray and there's an exclamation mark under the song. Can someone help me? I've checked and ensured that I followed every single step here: https://support.spotify.com/us/article/listen-to-local-files/

Reply
3 Replies

Same issue happened to me. You added the local files to your playlist, the playlist shows up on your phone and you try to download the songs, it says Downloaded, but they didn't actually download and are greyed out. These are the steps that should solve your issue since it worked for me. Both devices must be connected to the same Wi-fi network or else this won't work.

 

What you should do is first make sure both your phone and PC are connected to the same Wi-fi network. This won't work if your computer only has Ethernet capabilities, so you may need to look into getting a Wi-fi adapter for that. Then log out of Spotify on your phone, log back in, and try downloading again. They should download this time. On Android, go to Settings and toggle off "Download using cellular" because you're gonna be downloading using Wi-fi. For iOS users, go to Settings > Local files > Switch on Local audio files. If that doesn't work, switch to cellular instead because sometimes Spotify won't download songs if you have an unreliable internet connection. That, or switch back to Wi-fi and try again. Also make sure that Spotify on your phone and PC are both up to date. You could also try maybe deleting the songs in the playlist or the playlist itself, send the folder to the Recycle Bin, restore it, try adding the songs again, and try downloading again. Make sure you have the right folder in the local files enabled.

 

If that doesn't work, try looking to see if Spotify is being blocked by Windows Defender or a vendor firewall (i.e. Mcafee, Norton, ect.). If it is, try giving it access private and public.

 

Maybe this is some sort of bug in the Spotify app and I'm hoping it gets fixed in a future update. That, or Spotify needs to recalibrate/sync the local files again.

sadly didn't work for me. Thanks though!

Hey there @user-removed,

 

Thanks for getting back to the Community!

 

Apologies for the delayed response, we just came across this reply.

 

If you're still having trouble with this, we'd recommend checking your firewall settings and making sure that Spotify is not blocked there.

 

If your issue persists, it might be a good idea to use a different network and turn off your VPN if you're using one.
 
We'll be on the lookout for your update. Give us a shout if you have any further questions.

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts