Announcements

[Nest Hub 2.Gen] Display stays on, when Podcast playing

[Nest Hub 2.Gen] Display stays on, when Podcast playing

Plan

Premium

Country

Germany

Device

Google Nest Hub 2. Generation, newest version

Operating System

Android

 

My Question or Issue

To fall asleep, I listen to podcasts via Spotify on my Google NestHub. For about two months now, I've had the problem that the screen no longer dims/shuts off in the evening when a podcast is playing. The display is so bright that I can't sleep. When I play a song, the display switches to night mode as usual. The problem only occurs when I play a podcast. You can listen to many podcasts outside of Spotify, but especially with the Spotify Exclusives it is even more annoying.

Please fix the problem. It annoys me so much every night how a problem like this goes unfixed for over two months.

 

PS: I have tried everything. Reset Nest Hub, reinstall app, install spotify beta version, install spotify public version. Nothing could fix the issue. 

 

Thank you and please, please fix this 😥

Reply
15 Replies

Hi @erik1900,

 

Welcome to the Community and thank you for posting.

 

To start, we'd like to make sure if you're playing the podcasts directly from the Nest Hub, or if you've tried streaming them from your phone using the Connect feature.

 

Also, please let us know if your Hub has its firmware up to date.

 

We'll be on the lookout.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hello, I have streamed the podcasts to the NestHub via the Connect function.

NestHub firmware is up to date and I am not using beta version.

 

Thank you

Hi there @erik1900,

 

Thank you for your reply and confirmation.

 

Can you perform a clean reinstall of the app? This will make sure there's no old cache files causing this.

 

Another useful step to try is to restart your router.

 

Keep us posted.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Hey,

i have already performed a clean reinstall. I also used a different smartphone. The problem remains the same. I think that the problem is in the NestHub functionality and not in the smartphone.

I can imagine that the NestHub thinks that the (audio) podcast is a video and leaves the screen on accordingly. That would make sense for VideoPodcasts.

I think the reason for the issue here is the lack of distinction between audio and video podcasts.

 

Thank you

Hey @erik1900,

 

Thanks for the reply.

 

It would be great if you can let us know the following info, so that we can report this to the right teams:

  • Nest Hub exact model and Firmware version 
  • Your phone's model, exact OS version
  • Spotify version

Cheers.

 

 

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hey,

 

  • Nest Hub exact model and Firmware version 
    • Nest Hub 2. Generation
    • Fimware: 1.56.265669
  • Your phone's model, exact OS version
    • Google Pixel 5, Android 11
  • Spotify version
    • App on Pixel 5: 8.6.74.140

 

Thank you!

Hey @erik1900,

 

Thanks for the reply and the info.

 

Could you try switching on the "Download audio only" option in the Spotify mobile app, download some podcasts and try streaming them via connect, see if the issue still remains.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hey,

Thank you for the suggested solution. Unfortunately, the problem persists.

Hi there @erik1900,

 

Thank you for your reply and confirmation.

 

We've forward this to the right folks and we'll be on the lookout for other reports, as we might need more information to get to the bottom of this.

 

Let us know if we can help you with anything else in the meantime.


Have a great Friday and a wonderful start of your weekend.

 

Take care!

 

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

I have the exact same problem (including context - nest hub 2, Germany, only Spotify podcasts)

I have also the exact same problem, nest hub 2, also in Germany, only in Spotify podcasts. I would switch to another app, but Spotify has some exclusive podcasts, which I don't have in other apps, so please fix it Spotify!

I have had this same problem for the last 3-4 months. Music and podcasts keep the screen from going to sleep. 

This issue persists. How is this unresolved, after nearly a full year?

I should clarify - environment is Nest hub 2.0, System version: 309385, Cast version: 1.56.309385, Language: en-US (location USA), casting a podcast via Spotify connect

Hey folks,

 

Thanks for your replies in this thread and for the info shared.

 

Just to confirm, would you mind sending us the troubleshooting you've tried so far? This way we can avoid repeating any steps.

 

On another note, to continue investigating this, we'll need you to send us the following:

Keep us in the loop!

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Suggested posts