Problems with downloading playlists

Problems with downloading playlists

I have two problems with downloading my playlists for offline usage

1: not all playlists are downloaded completely. Some are, some won't . They keep getting stuck at a certain percentage (say, 12%), and won't continue downloading (no icon appearing in the top left corner, no progress, no download icon in the overview of playlists). I have tried cancelling and redownloading, I have reset all my data for a fresh download, but the problem persists.

2: local files on my laptop that are integrated in the playlists that I want to download are not downloaded at all. Both my phone and the laptop share the same device, but they tracks remain grey in the playlist on my phone. The tracks are in normal mp3 format. Nothing special there. 

I use the latest version of Spotify on Android 2.3. Just to emphasize: I have already resetted all data to start over again numerous times, but the problem persists. Any help is appreciated! 

5 Replies

I have the same problem (no. 1)



Good news: problem 1 is solved 🙂 The solution was awefully trivial: my sd card was full. My confusion came forth from the fact that this was the first time that I downloaded everything in extreme quality. Hence I couldn't put the same number of tracks on my sd card. 


Problem 2 is still there. I haven't got a clue how I can synchronize local tracks. Both my laptop (which has the local files) and my phone share the same wireless network, so it should be able to work.



I have had the same problem and for some reason my songs will download only after I have played them (given that they are in an offline playlist). It takes some time, but at least it works.

Thanks for that! Since newer versions of the software (mobile and / or desktop; I don't know which of the two made the difference, if any), synchronizing local songs works again. 

Huwawei Ideos X5 phone, Android 2.2.1, Latest Spotify app.


Syncing over WiFi:

syncing starts, downloads sometimes a couple of %, then stops. Sometimes I get the message 'no internet connection available'. Browser, store and other apps have working connection. I have synced just fine before. Tried clearing app cache, no go.

Suggested posts