Help Wizard

Step 1


Sleep timer not working with podcasts

Sleep timer not working with podcasts

I use some podcasts to help me get to sleep, but I've noticed that the sleep timer doesn't work with them, episodes keep playing even though I set the timer to stop playing after the episode or an hour. 

Is this a known issue? 







Google Pixel 4a 

Operating System

Android 11



48 Replies

This is happening to me despite not listening on a connected device. It just started happening a few days ago. Keeps playing despite the sleep timer being turned on. 

I’ve also just recently started having this - also not using a connected device. Started maybe Sunday or Monday night despite it having worked on the same podcast just last week!

I experience the same problem since some days. iOS though... Hope there will be a fix soon.

Hey everyone, 


same here. I tried different podcasts but it won’t stop playing even if the sleep timer has been set.

That’s super weird as it worked until some time ago and when listening to music this is no problem at all. 
reinstalled the app, tried it on other devices and so on… still not working. 
so hopefully there will be a bug fixing soon 

Hey there folks,


Right now we have an Ongoing issue with what you seem to be experiencing with the sleep timer. We'd suggest to go ahead and check this thread.  Feel free to leave your details there as well.


Keep an eye on the page for any updates. It'll also be useful to subscribe via the three-dots menu in the top right corner next to the title. That'll make sure you stay up to date with any relevant updates about this.



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

I am also having this issue but I don’t have any connected devices. I’m listening to the same podcast as seen in the pictures. I set my iPhone on charger for the night with the episode I selected and  turn on sleep timer for end of episode. When I wake up in the middle of the night it’s still playing and on a different episode entirely. 

I have a basic work around.

I added the single episode to a new playlist called "SLEEP" and then in my library I play the playlist. The episode will end and nothing will play after it. You can check the queue and it will be clear. 

Hope this helps 


The issue seems to still not be fixed. I'm using the sleep timer to directly play from my phone (iPhone), no connected devices whatsoever. It just plays the full playlist instead of stopping. Did all the hard resets I can, but it's really bothering that it's not being fixed...

For those who have this problem and see this, for me it helped to disable the crossfade so that after each episode comes an "end". Since then I never had the problem again, whether a device was connected or not.

Suggested posts