Help Wizard

Step 1


Songs don't play at the beginning

Songs don't play at the beginning






(Moto G Stylus 5G)


My Question or Issue

Every so often, random songs won't play at the beginning, and before you ask,

I do have crossfade on set to 8 seconds, but the song won't start at 8 seconds.

The song starts a whole 1 minute into the song, randomly, there's no pattern to it.

This has been happening for maybe a year, maybe less, kinda sucks.

7 Replies

Hey @Orion_


Thanks for reaching out to the Community about this.


The behavior you're describing seems very odd. Can you let us know if you've already tried to log out > restart your device > log back in? 

It's also a good idea to try a clean reinstall to clear any old files that might be causing issues with app's performance. After that, give your device a quick restart as well.


If your issue persists, please send us a short video of what is happening exactly on your end and also feel free to share the make, model and OS of your device, so we can take a closer look and advise you better.


Let us know how it goes. 

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

There is NO advanced settings under my profile (mac desktop) - crossfade is the worst thing ever - and I will cancel my sub if I can't turn it off. It's skipping UP TO 57 seconds on some songs. CRAPOLA. I can't delete musicians either on desktop .

Found the crossfade button, turned the slider to 0, turned it off, restarted Spotify, cleared the caches, repeated it three times, off or on with 0 seconds no change. Spotify believes everyone is listening on a phone. Dumb. And YES, I tried it as ON and 0 seconds same deal. Next song started at 1.11 (U2 streets have no name). A MINUTE AND ELEVEN??


this is also happening on the web player (Firefox 110, on Xubuntu), which has no settings at all, other than the option to switch languages.


some people can only use the web player, or might prefer it. so existing settings should 1) work, and 2) be available on all platforms/devices. having to download an app just to change crossfade or autoplay settings, as we currently need to do, doesn't make sense.

Hi folks,


The feature you're referring to is called Automix: some Spotify playlists have a custom crossfade, which is why some songs start a minute in, for example. You can turn it off in the app's Settings > Playback. More info here.


This feature should only be available in the app though. @unseenlarks, have you tried using another browser to see if there would be a difference? In case Automix persists, please share a short screen recording which captures the behavior in action, along with the following info so we can investigate further:

  • All browsers you've tested with and their versions.
  • Any other troubleshooting you've tried.

Keep us posted!

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

i'm aware, but this is not it. Automix and crossfade were not enabled. this was new behaviour.


for the time being, i'll chalk it up to a temporary glitch on Spotify's end. tried to reproduce the issue today (no settings changed on my end, using same browser) and it hasn't been happened so far.

Hi @unseenlarks


Thanks for keeping us in the loop.


We're glad to know that it's working now as expected. If the issue comes back, please send us the info @Yordan asked for previously so we can take a closer look. 


Have a great day 🙂 

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Suggested posts