Help Wizard

Step 1


Spotify App crashes when it connects/disconnects from Internet

Spotify App crashes when it connects/disconnects from Internet






Samsung J3

Operating System

Android 5.1.1


My Question or Issue

The spotify app is consistently crashing every time my phone picks up or loses an internet connection. E.g. when moving out of range of a modem it will crash as soon as it can no longer detect a connection, forcing me to manually restart. This also happens when I enter into range of the same modem. I have tested this by switching off my phone's wifi and running the app without incident for >2 hours, and then the app immediately crashed when I switched the wifi back on. The app seems incapable of running for more than ~10 minutes without crashing in its current state.


I have performed two complete reinstalls at this point, neither one helping in any way. The app seems to be updated to the most recent version ( I have also tried the solution presented here ( without success.

6 Replies

Hi, I have the exact same problem. Ever since a Spotify update around 2-3 weeks ago, my Spotify app started crashing as soon as my Android connects to wifi.  I have reinstalled 3 times, no luck.  These fellows have it too:


Thanks for bringing this to our attention!

Could you please follow the steps in this post in the exact same order as given there and let us know what happens?

We're here for you 🙂

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

I know they've said they fixed it but the recent update has killed 3 phones and support can't fix.  Connect to wifi doesn't work.  Connect to mobile data fine.  Only for the app though - streaming from a web window is fine - go figure...

Hey there @LBDuck


Thanks for posting on the Community about this. 

Can you confirm if the app is still crashing after performing a clean reinstall on your device? We recommend giving it a try as this step gets you a fresh copy of the latest app version with all necessary updates. 


In case this persists after the clean reinstall, try disabling any battery optimization or data cleaning settings and apps on your mobile device. Make sure you try this since such features can often prevent the app from operating at full capacity.


Keep us posted! We'll be happy to lend a hand if you need more help.  

Hi @Ivan - I've done multiple clean installs both on my own and with the support team - been in the chat with support for hours an no luck.  Then this morning a new version appears in the Play Store (about 4mb smaller than the last) and installed fine and fixed the issue on all 3 phones.  This only started happening after an update last week - nothing else changed in my home enviro as I'm the admin - so had to be the last update.  Now I'll turn off auto updates for this since it's working.


One strange thing I kept noticing with the version from last week is it took ages to install (literally minutes) which you normally never see - the new install took seconds which is what you expect so something significant was changed.

Hi @LBDuck,

Thanks for your reply.


We'll pass your feedback on to the right team, as this information is valuable to us. Also glad to hear that everything works fine now.


Don't hesitate to give us a shout if you have more questions in the future.



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts