Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify app doesn't list Sonos Speaker, but Sonos App can play Spotify music on it

Spotify app doesn't list Sonos Speaker, but Sonos App can play Spotify music on it

I have 5 sonos Speakers and a Spotify Premium account.  I am using spotify on my Android (Pie) phone and Mac OS computer.


On both devices listed above, I can play Spotify music on my Sonos speaker (called Lounge) when I use the Sonos App.  But if I use the Spotify App, the speaker called Lounge does not show up.  The other 4 speakers show up fine.


I have restarted speaker, computer, check for upgrades on all devices, etc.

51 Replies

Same issue today.

15 May 2130 CET: Got a tweet saying they were looking at it.

It seems to be working now, with no changes here, other than walking away and coming back 3 hours later.

Similar problem with the Spotify app started a few days ago-  Spotify app sees the Sonos zone (I have a Sonos Connect) and says it's connected but no sound.  The Sonos app plays Spotify fine, but it's less convenient than controlling through the Spotify app.

Hey folks,


Thanks for reaching out to us about this!


We've found some useful instructions on the Sonos support site which say the following:


I don’t see my Sonos speakers listed in the Spotify app.
Your Sonos system and products will need to be linked to your Sonos Account. Once complete, the Sonos speakers will show up under “DEVICES AVAILABLE” in the Spotify app.


If you still do not see your Sonos speakers or are not able to play to them, make sure you are on the correct WiFi network, and reboot your router. If you're still unable to play to Sonos from the Spotify app after the router is rebooted, please contact our support team for further assistance.


Let us know how you get on! We'll be right here in case you need anything 😉

My situation is slightly different. The Spotify app still shows my Sonos "Connect" and still lets me click on it. My problem is that the Sonos speakers stay silent. When I do the same thing with the Sonos app, everything works fine. I should mention that I've been successfully using the Spotify app to play my Sonos system for many months now. It's only recently stopped working.

Hi. My problem went away on it's own. I suspect that Spotify fixed some problem on it's servers, but we will probably never know. As far as the info on the web site, I had already tried doing everything that I found documented.

Hey @craigmcg - glad to hear that the issue has resolved itself 🙂


@user-removed - have you made sure that your Spotify account is linked to your Sonos account before selecting the Sonos device in Connect? If yes, then could you try unlinking/relinking the two accounts by following the steps in this support article?


Keep us posted 🙂


I have been having this issue for a few days. Uninstalled the Spotify app and all my Sonos speakers came back, Next day they have disappeared again. I have reset everything and checked all network which is fine. Spotify works fine through the Sonos app which works without issue. This is using the latest Spotify app for IOS. On my wife's iphone which is using an older version of IOS the Sonos speakers are visible and everything works. Is this an issue with the app?

Hey @Bumrah.


Thanks for getting in touch with us about this 🙂


Can you confirm you've tried the steps we've recommended in the thread?


If none of those worked for you, let us know and we'll look into it 😉

Hi, yes and I have managed to sort the problem out. Basically it was my BT
Smarthub causing the issue. There is a setting called “Smart Setup” which
needed disabling. Not sure why but when I disabled it the problem was


Hi Peter, I am experiencing the exact same issue.

I have done the settings correctly as the FAQ instructed and repeated what you have suggested.

Could you please kindly follow up this issue? It is obviously not an isolated case.

I have the same issue and have tried evrything listed here but still no luck.

I tried something today that made the problem even worse. 
I have a Sonos 5 (older version) and a Sonos One. Spotify only lists the Sonos One.

So I went in the Spotify app, started playing something on the Sonos One and then chose to "Group Rooms". Once I have both rooms grouped it plays. However, if I choose to remove the Sonos One from the group the music plays for 0,5 second on the Sonos 5 and then stops. Also the spotify app jams aswell and I need to restart the app for it to work. 
I have linked my account on Sonos and Spotify, updated everything i could, reset my router and said a little prayer but nothing seems to work.

My guess is that it has something to do with software for older products but i'm not an expert.

Same issue a year later.

I have the same problems. For me the one Sonos component Spotify won’t play nicely with is a Play:3 and is my newest component. It is fine with my old OG Play:5.

I do wonder if it is because that speaker is possibly furthest from my router though other kit eg laptop etc manages fine in the same room.

I've also been experiencing this issue, except none of my speakers show up through the Spotify app. It all works just fine via the Sonos app.

Uninstalled then reinstalled Spotify app and it did the trick.

I went round the combination of switching phone on and off, speaker on and off and restarting app and one of those seems to have fixed things. 

Hey Peter! I’ve recently changed my wifi router and updated all device connections which resulted in a problem above. I can play songs through my Sonos app without any problem but the Spotify Mac desktop app (nor the iOS app) doesnt list my Sonos One speaker in the Spotify Connect panel. I reinstalled the Spotify app on my phone, but before that, I deleted the Spotify service in the Sonos app and reconnected with my Spotify account through the web. Still no luck. One more addition: my new Alcatel router is using an unlimited 4g connection, I’m not sure if that’s a problem but the **bleep** never sleeps...

Suggested posts