Won't Stream on anything other than wifi (telstra aus, using ipv4 apns)

Won't Stream on anything other than wifi (telstra aus, using ipv4 apns)

As stated above, spotify will only stream on a wifi network, wont recognise my data connection (4g) I have a Galaxy S5 and am with the telstra network in Aus. I Have done lots of searching and have tried many other options (Uninstall, reinstall, wipe cache, wipe entire app data, sign out and back in, sign in with facebook, dissconect facebook from account. The only thing that has worked is if i open the app, then open the app draw and close down spotify then reopen it will stream half a song maybe before it says no connection avaliable again.


At this point I am about ready to migrate to Play Music, I already have a free account with them and have none of these issuse, I am tired of paying for spotify when it doesnt work as it should.


Thanks in advance for the help,



1 Reply

To me it sounds like your device or network causing the issues rather than the Spotify app? If it were there would be lots more reports of this issue. Can you check your APN settings match the below: 


Name: Telstra Internet
APN: telstra.iph
Proxy: Not required
Port: Not required
Username: Not required
Password: Not required
Server: Not required
MMS proxy:
MMS port: 80
MMS protocol: WAP 2.0
MCC: 505
MNC: 01
Authentication type: Not required
APN type: default,supl,mms


If you're still having trouble I would recommend getting in contact with Telstra and seeing if there's anything their end that could be causing you the issue.

Please use the search feature before posting a problem/bug/idea.
What's a Spotify Rock Star, and how do I become one?
     Using Spotify Since March 10th 2009
     Twitter: @mechanimal82

Android Troubleshooting:
[COMPLETE GUIDE] How to fix most Android issues
Spotify Android Version History

Suggested posts