Help Wizard

Step 1


"Autoplay" option missing from "Settings" page

"Autoplay" option missing from "Settings" page






Google Pixel 7

Operating System

Android 14


My Question or Issue

Up until recently (around 12/1/2023), "Autoplay" (or was it "AutoRepeat"?) in "Settings" was set to Off, as was "Autoplay similar content".  When an album finished, there was silence.  That is my desired behavior. 


Now when an album completes, it automatically repeats. The "Autoplay" option is no longer present on the "Settings" page. 


When searching this community for an answer, all the posts refer to this "Autoplay" option, as though it should be present.


Note that I do **not** use Spotify on any other devices, including my laptop.  When I did open Spotify in a browser, there are no Autoplay settings.

2 Replies

Hey @BikerDanUSA,


Thanks for posting in the Community and welcome.


It sounds like the behavior described is due to the on repeat option. This option can be found in the Now Playing View and looks like this:



When the on repeat option is enabled, any playlist/album you play will be repeated. We suggest you double-check if this option is disabled. To do it, you just need to tap the icon twice. One tap will activate the loop option, two will disable both options. Give it a try and let us know how it goes.


If you're unable to deactivate this feature (or if after disabling this behavior continues), we'd recommend you log out and log in twice in a row onto your Spotify account. This could sound a little bit odd, but this way the system will force a re-sync of your account in general.


Lastly, if this continues to happen, would you mind sending us the exact Spotify version you're running there? It'd be awesome if you could send us some screenshots of this behavior, so we can better visualize what's happening on your side.


Keep us in the loop!

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

AlejaR. Repeat is not what the OP was asking about. THE AUTOPLAY toggle is not longer in settings. User no longer have the ability to disable Autoplay.

Suggested posts