Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


stop spotify creating song radio base on (the first song that u choose)

stop spotify creating song radio base on (the first song that u choose)



Samsung galaxy

Operating System

 Android Oreo


My Question or Issue

How to stop spotify creating "song radio based on *the first song that you choose after searching  an artist"


7 Replies

Hey @4zmbs3a6-_h79, Welcome to our Community.


Hope you are enjoying summer!

In order to do so, just go to Settings, find Playback then look out for Autoplay. Just tap to switch it off and you should be good to go!


Have a nice day 🙂

  • Its not working on me

Hey @Bedeee,

I know it sounds simple, but it's often overlooked. Could you try restarting your device? If that doesn't help, try a quick clean reinstallation of the appreinstall. Just follow the steps here.

If you're still having trouble, could you let me know the exact version of Spotify and the exact version of the operating system you're running?

I'll see what we can suggest!


Thank you for your answer.

still the same tried restarting my phone and uninstalling spotify also deleting data with my autoplay turned off.

Spotify vesion armV7

Android 8.0.0


Thank you

Hey @4zmbs3a6-_h79,


Thank you for the information!

Could you please tell me which ones have you tried from the list below?


  1. Try a soft reset (reboot the device).
  2. If that doesn’t help, try a clean reinstall. Be sure to locate and remove any Spotify folders or cached data from your device before reinstalling again.
  3. If that doesn’t work, update your device’s firmware (if available).
  4. If that doesn’t work, try clearing your device’s cache.
  5. If that doesn’t work, try using a different WiFi connection (please note that streaming dover mobile data might incur additional charges). If this works you probably need to restart your router.
  6. If that doesn’t work, try removing the SD card (if your device has one) and try again. If this works you might need to format your SD card.
  7. If that doesn’t work, ask a friend or family member who also uses Spotify to log in to their account on your device. If everything works for them it’s likely the issue is with your account. If not, then it’s probably an issue with your device.

I will then bring this to the attention of the right folks at Spotify 🙂

Hi LorenXK

I tried all that restarting and also clearing my cache and also clear the data. Mobile data or Wifi is the same it always do the "song radio based on the first song *** rather than playing from search.

I tried playing on different device with my account it works fine.

The other device spotify version is

My version on this device is armV7


Do you think its the version on my device is the problem?


Thank you

I see you tried it on an iOS device.

It might be because it is difficult to point at which might have the fault for it.

If you haven't clean installed Android on your phone for a long time it might help.

I will look further into it and let you know.

Please ask for anything if you need help 🙂

Suggested posts