Help Wizard

Step 1

NEXT STEP

Not Getting Past ‘Connect to Power’

Not Getting Past ‘Connect to Power’

Plan

Premium Duo

Country

USA

Device

iPhone XR

 

Operating System

iOS 16

 

My Question or Issue

When I received my Car Thing I took it to my truck and plugged it in which pulled up a screen saying ‘Use Adapter! To power Car Thing, use the adapter provided with your device’. I promise I am using the cord and adapter provided with Car Thing, I’ve tried putting the adapter into the various outlets of my truck to no avail, even tried it in my Fiancé’s car to show me the same message.  The plug into the back of the Car Thing seems lose and the cord has fallen out. If turned wrong the screen turns off. I dont know what to do and was really looking forward to having this. Is there any other trouble shooting i can do other than what was prompted to me on the support.spotify.com website? 

Thank you for taking the time to read this. 

 

 

Reply
7 Replies

Hey there @TugColt2017,


Thanks for the post.

 

Sorry to hear that this is happening with your Car Thing.

 

Can you try to push in the power cable a bit harder into the Car Thing. Some users report that they need to do this the first time they plug in the car thing.

 

Let us know if that helps.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I am trying to set up the car thing but when I plug in the 12v adapter, it says “To power Car Thing, use the adapter provided with your device.” I am using the one it gave me? Help! 

That’s what it is telling me too!

Hi Alex,

 

I did try that- well my fiancé took it and did that- but no change. 

I had the same problem until I realized that the USB-C plug was NOT plugged all the way in. It seemed impossible but it can probably go in further. For reference, this is mine plugged in after a little bit of force, you do feel a click once it is in. Take your time so you don't break anything. Good luck!

 

IMG_0465 - Copy.jpg

This worked for me!!

This was my issue as well. It took some firm pressure to seat the plug in all the way and then it clicked into place like your photo. Thank you for posting this!

Suggested posts