Announcements

Desktop Linux sends a notification each time a song starts

Desktop Linux sends a notification each time a song starts

Spotify Free plan

Desktop Linux on Fedora with GNOME and Wayland

 

Each time a song starts a notification is sent on the desktop. So I have two notifications in the gnome panel: the normal song playing notification with play/pause, and a normal notification with the name of the song. It shouldn't have the second notification with the name of the song. It's pretty minor but a bit annoying, like when my computer is asleep it wakes up to display the spotify notification. No other app does this. I'm using the spotify app instead of the website mainly to listen on an external speaker.

Reply
1 Reply

Option 1 - In Spotify top right under username go to:

  • Settings > Display >
  • Disable "Show Desktop Notifications when a Song Changes

This will prevent Spotify sending that second notification, the current song notification with player controls will still be there, but will not pop up as a notification each time. this should also stop notifications on the lock screen, but if this still occurs, go to the Gnome Settings App

  •  Notifications > Spotify >
  • Disable "Lock Screen Notifications" and any other settings that you don't want

Suggested posts