Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


I can't open Spotify in Ubuntu


I can't open Spotify in Ubuntu


Since the last update I have a problem. I run Spotify but nothing happens. Do not know how to fix it. Can anybody help me please?



Accepted Solutions
16 Replies

Hi there and welcome to the community,


What Spotify Version do you have? Could you try doing a full reinstallation, including removing your local cache files.

I don't know the exact location of the cache files on Linux, but could you try the following path?

What's a Spotify Rock Star, and how do I become one? | Twitter

Backstage Intro - Meet Jordi!
What's it like to be in a Spotify Office?

Did I help? Please add a like!
Did I solve your issue? Please accept as the solution!


Yes, I tried doing a full reinstallation and nothing (i deleted also the cache files).

I do not know how to know which version I have but I imagine it is the last.

I need the music! :_(

1. When you start spotify in the terminal, you should see error/debug messages

      Can you check if you see there something that could help?

2. spotify version

      search in your package manager for spotify and you'll see it

      OR type in your terminal:

         dpkg -s spotify-client


1.- Ok, I do the following to open spotify in the terminal:
          sh spotify-client
      The message I get is:
           sh: 0: Can't open spotify-client

2.- My spotify version is: 1:

Thanks for your help... I'm desperate

to 1: 


the command sh is to execute shell scripts

spotify is a binary, you can start spotify just by using the name


so, best to do is:

1. open terminal

2. type spotify + press TAB (TAB finds all binaries on your OS which start with spotify)

3. select the binary you want from step2

4. press ENTER


I do not understand very well.

I open the terminal, I type spotify and I press TAB but I get 148 possibilities. Which is the binary I have to choose? There is no binary called spotify


niklas@niklas-thinkpad:~$ spotify &
[1] 22841
niklas@niklas-thinkpad:~$ spotify: error while loading shared libraries: cannot open shared object file: No such file or directory

This error occurs since a couple of weeks. Before that it worked just fine. I'm using Ubuntu 12.04 LTS and tried also a reinstallation on my machine. I heard about a quite similiar error on Ubuntu 14.04, but it seems no one but me has trouble with 12.04.

Ah, ok. Then I have the same problem.

kike@kike-X200CA:~$ spotify&
[1] 10891
kike@kike-X200CA:~$ spotify: error while loading shared libraries: cannot open shared object file: No such file or directory

What is the solution? Reinstlall the library? How?

Hi, I am having the same problem here, but I have Linuxmint 13 Xfce since I have an not-so-old-but-a-bit-older computer.


I have read and followed I don't know how many blogs and posts about installing Spotify. I have installed, uninstalled, added keys, checked and edited the source.list and source.list.d file/folder... there is no human way for me to run spotify.


I even tried typing "spotify" on a terminal, then pressing TAB... nothing, not even 1 miserable binary appears, and I can see the Spotify icon in my menu, under Multimedia. But! When I typed "spotify" on the terminal without pressing TAB, I got some signs of life from my computer:


spotify: error while loading shared libraries: cannot open shared object file: No such file or directory


So! after a bit of research on internet, I tried this:

sudo apt-get install libudev1:i386


And I got the following answer from my computer:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libudev1:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'libudev1:i386' has no installation candidate


In other words: Computer says NO!


Is there any way, anything that I can do to get Spotify running on this computer?

Everything else works perfectly fine.


Thank you very much in advance!

@punktino @PHPNick @tobetiano

please read this thread (1) completely and try the few mentioned approaches that helped them (e.g. comment by @Skanda here (2))


Since above are some i386 systems: there's a thread that statesthat the new spotify doesn't run on 32bit 😞




No, it did not work

Smiley Sad


However thank you very much for your help

ddi anyone solved the mystery?

nope, i use spotify web

Marked as solution

It actually works. Thank you very much, my friend

It really works! Nice job man. You saved me from too quiet working saturday!

Suggested posts