Help Wizard

Step 1


Joe Rogan Experience JRE doesn't work with Linux


Joe Rogan Experience JRE doesn't work with Linux


Premium Family





Desktop Nvidia 1070 TI, Intel I7, 16 GB Ram

Operating System

Ubuntu 18.04 bionic (x86-64)



My Question or Issue

When I attempt to listen to or watch JRE I get an error "Sorry we're not able to play this video." But I don't hear any audio either.



Accepted Solutions
Marked as solution

Great yeah this totally worked thanks


sudo apt install libatk-adaptor

View solution in original post

21 Replies

Experiencing the same here. It show the first frame of the video, and I hear like half a second of audio (so all the necessary codecs seem to be available), but then it claims it can't play the video and gives up.

Same problem here. Sometimes I hear a second of audio, then it jumps to the next track.
Spotify free on Ubuntu 20.04 (x86-64). Laptop ASUS ROG with Intel i7 and GeForce GTX 1050

I have the same issue.

Using Ubuntu 20.04 with Firefox 80.0.1. Linux Spotify app shows as Spotify connect. Doesn't load episodes or able to play them. Switching to Firefox web player also not functional. @Spotify engineers please address this none functionality for paying customers, much appreciated. Thank you.

Come on spotify, this have to be fixed. I'm using linux on a Lenovo T490. Not cool. I'm on Premium family too.

I'm guessing that Spotify doesn't read community messages.  Maybe it is just to talk about cool music.

Same here, i get the JRE logo and sometimes half a seocnd of audio, it just skips through the playlist like I'm mashing "next"


Device: Ubuntu 19.10 / nVida GFX / AMD CPU.
Client Version: 1:

That’s exactly what I see and a better description than what I provided.

Same here (plan: Premium, os: LinuxMint). The desktop app does not play video. The browser version works though.

 I guess it is time to flood support tickets about the issue

the problem is only with JRE.
all other podcasts work no problem.

Having same issue but not on Linux.


Both app and web version don't play any audio (forget about video!).


I can get audio if I turn my VPN off. If I must, I'll listen this way, but I shouldn't have to.

Pop OS 20.04 (basically ubuntu 20.04) same issue here. Music works fine, JRE video does not. Works find in browser.

I'm experiencing problems as well on Linux and Android. No episodes playing, no audio or video. It just jumps to the next episode. I can download episodes but not play them "in my location". Tried changing location using my VPN but no luck. What a drag. The only podcast on Spotify that I can't play from what I can tell.


What's the point of having an exclusive deal on a podcast if it's just gonna be pirated and played elsewhere?

It seems there was an update. I found it odd when I needed to log into the client again today, so I check the version.


It is now


However, it still does not play the JRE videos, but now it does display a message at the top saying it cannot play it.



Marked as solution

Great yeah this totally worked thanks


sudo apt install libatk-adaptor

I have the same problem but the solution doesnt fix it. Am I the only one?

Suggested posts