[Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

Solved!
Reply
1 person liked this

[Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

sleeksorrow
Roadie

So 6 months are over again and like every 6 months, Ubuntu releases a new distribution version and like every 6 months, spotify cannot play local files because of avcodec version mismatches.

 

Spotify still searches for e.g. avcodec54, while artful brings avcodec57.

 

I know this is not that easy and - for some reason I don't understand - you chose to not bring your own fitting avcodec bundled. But if you choose this path, why can't you try the next Ubuntu version while it's in beta and update spotify accordingly, so it will work after upgrading?

 

Pretty please find a solution for this that will

a) reach us fast

b) last longer than 6 months.

 

Think about bundling the correct libraries. Or think about snap packages maybe. **bleep**, make docker container if you fail so hard to meet all dependencies... But please bring an end to this odyssey.

 

Thanks.

 

Edit: I see the opposite of heaven is not welcome here. Apologize. Blame AC/DC.

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

sleeksorrow
Roadie

I just learned that Spotify really is providing a Snap packages like I proposed, and this package resolves all those problems, just as I thought.

 

I would have loved some spotify support rep had to pointed me to this........

17 Replies

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

QuiriniusGast
Roadie

How can you expect from Spotify to accomodate all distro's? The world is bigger than just Ubuntu.

 

You don't hear Fedora users (also two upgrades a year) wining about this. Perhaps it's more of an Ubuntu issue? I upgrade my pc twice a year and Spotify always works afterwards with Fedora. One of the reasons why I moved away from Ubuntu, it's a crappy distro.

 

Linux users are expected to fix these issues by themselves, or switch over to Windows if it's too complicated. For everyone an alternative.

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

sleeksorrow
Roadie

Yes. You are absolutely correct. This is not about Ubuntu. And this is not about Fedora, too. But if you care, please look for a Fedora user that can play local files with Spotify. If you would know fedora, you would know that this comes with libavcodes 57 as well and it also suffers from just the same issue.

 

No, this is not about what you purport it would be. This is about using clever recent packaging methods that are distribution independent. This is about delivering a complete software package that will include everything that is needed.

 

This is about Snaps.

 

This is about Flatpak.

 

Despite this, please explain me how to "fix yourself" a problem when a closed source application is linked against libraries that you don't have and that you cannot downgrade without ripping your distribution apart. I'm curious to hear your suggestions that go beyond trolling like "use Windows if you're too dumb".

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

QuiriniusGast
Roadie

Let me check and come back to you on my own pc with Fedora. I need to upgrade to the latest version of Fedora anyways so it's a good experiment to narrow this down.

 

Regarding local files, and not saying you are doing this, but many people have a bunch of illegal mp3's that they want to play through Spotify and not sure why we are entertaining this behavior.

 

Regarding your comment about delivering a complete package, we both know that many Linux applications are not doing this, but able to get all the dependencies from repo's when required. This way we have a nice lean OS, and not a bloated one like Windows. Don't have any issues with this.

 

And no, I'm a Linux advocate and like to see as many people as possible to use Linux, so I'll never suggest to you to go back to MS.

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

sleeksorrow
Roadie

Thank you. On my side I straced spotify to find out which libraries are wanted but not found and tried to hand those to Spotify using a separate directory which I have added to LD_LIBRARY_PATH. This has worked in the past, but at the moment I don't succeed with this approach. Maybe I have overlooked another library, maybe the libraries from the older distribution are being built with a gcc version that's not available anymore. I don't know yet.
 
The thing that makes me sad is, that this should not be needed, as there are new (snaps, flatpak) and old (static builds) mechanisms available that would make this Odyssey obsolete.

 

Regarding the "illegal mp3" thing: Correct. My use case is that I have lots of audio CDs of music that's not available on Spotify, and grabbed them into mp3 (legal in Germany, called "Privatkopie"), but want to combine them with music in Spotify playlists.

 

While you are right, that illegal music needs to be condemned, the approach of "well then keep bugs that make this burdensome" is a wrong approach. And the "well if there is a possibility that can be misused, then let's condemn it completely" is the wrong approach, too. "No crowbars for anyone", you know?

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

LinuxScouser
Casual Listener

I've been using Ubuntu for several years and continually had this issue upon every fresh install and having to fix it by adding older libraries was cumbersome. I'm now using Solus because I was interested in trying a new distribution and this issue is more difficult to solve as I can't simply follow the Ubuntu instructions to correct the issue. I also wonder if switching to snaps and providing their own libraries in said snaps would correct this and make life easier for the majority of Linux users.

Solution!

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

sleeksorrow
Roadie

I just learned that Spotify really is providing a Snap packages like I proposed, and this package resolves all those problems, just as I thought.

 

I would have loved some spotify support rep had to pointed me to this........

Highlighted

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

Lorenzo_NGG
Roadie

Well I cannot play local files since add local files button is not working anyway ...

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

sleeksorrow
Roadie

Try clicking the button, then minimize Spotify app and you should see the file dialog.

1 person liked this

Re: [Linux] Ubuntu 17.10 artful: play local files broken / avcodec version mismatch

Lorenzo_NGG
Roadie

Nope. No file dialog will appear. For me it’s just a “dead” button

SUGGESTED POSTS