spotify-client on Linux, update to libssl1.1

Solved!
Reply
Highlighted

spotify-client on Linux, update to libssl1.1

Casual Listener

Hi,

 

Is it possible to update the dependency of spotify-client linux to libssl1.1: https://packages.debian.org/stretch/libssl1.1

 

Also, libavcodec57 and libavformat57 😉

 

Thanks,

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution!

Re: spotify-client on Linux, update to libssl1.1

Spotify
Spotify

Spotify 1.0.69 in the testing repository now (soon stable) can dynamically load different versions of libcrypto.so (from the libssl* packages).

View solution in original post

5 Replies
Highlighted

Re: spotify-client on Linux, update to libssl1.1

Casual Listener

Indeed. Can't install on Debian Testing because of these issues. 

The following packages have unmet dependencies:
 spotify-client : Depends: libssl1.0.0 but it is not installable
                  Recommends: libavcodec54 but it is not installable or
                              libavcodec-extra-54 but it is not installable
                  Recommends: libavformat54 but it is not installable
                  Recommends: zenity but it is not going to be installed
Highlighted

Re: spotify-client on Linux, update to libssl1.1

Casual Listener

Sad 😞 I have been really happy with the linux version since I formatted the **bleep** out of the last windows install some years ago.. 😄 only the occasional VM for atmel studio.. blah

Really hope they will keep up the support, but I guess we are a pretty marginal userbase..

  

There is a workaround provided on debians wiki but it does not work for me.

 

Running with --show-console show packages being received with no errors when I start and stop different songs, but no sound.

And "Can't Play Current Song" showing at the top

 

Guess it's those *54 packages

Highlighted

Re: spotify-client on Linux, update to libssl1.1

Roadie

@paul - I've got it running on testing by installing libssl1.0.0 from jessie-backports, which actually uses 1.0.2 to create the package.  Main thread on the libssl issue here: https://community.spotify.com/t5/Desktop-Linux-Windows-Web-Player/The-return-of-the-libssl-trouble-o...

Highlighted
Solution!

Re: spotify-client on Linux, update to libssl1.1

Spotify
Spotify

Spotify 1.0.69 in the testing repository now (soon stable) can dynamically load different versions of libcrypto.so (from the libssl* packages).

View solution in original post

Highlighted

Re: spotify-client on Linux, update to libssl1.1

Casual Listener

It works for me, many thanks 😉

SUGGESTED POSTS