Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Playlist description not updating


Playlist description not updating

Premium Family Plan - USA

Device - Macbook Pro 2018

Operating System - macOS Mojave v. 10.14.4


My Question or Issue

I can't get already created playlist descriptions to update. Everytime I try to save an update to the playlist it reverts back to the original description. I've tried on multiple devices / accounts and I can't get things to update. 


It looks like this issue has been reported before but is still unresolved (


Accepted Solutions
Marked as solution

Hi! I was having the same really frustrating issue for a long time. I can't guarantee this will work forever, but it is working for me right now. When you make the edit and press save, then download the playlist. 
I'm hoping that eventually I can un-download the playlist and free up space, but this seems to be working now.

View solution in original post

25 Replies

Hey @missmccallkay.


Thanks for getting back to us.


It can take a few hours for the description to update. Have you tried updating the description and checking back the next day?


A quick reinstallation could also help. You can read here how.


Hope it will help! Let us know if you have further questions.


Have a nice day.

Sorry, but this ist not a solution at all - it's just another description of the problem.

Why Spotify still doesn't solve it, years after it was reported?

Yep, mine is doing the same thing right now and it's a huge nightmare as I'm about to launch a new playlist. reinstalling sounds brutal since it would probably wipe out saved to disk playlists.

Did you manage to fix it? It's really annoying

Hey folks, 


Thanks for reaching out to the Community about this. 

Just to confirm, have you tried a clean reinstall instead of the regular reinstall? We recommend this step as it'll remove the old drivers first and then install the new ones. It'll also get you the latest version of Spotify. This usually tends to solve issues like the one you're experiencing.


After the clean reinstall simply restart your device. Then try updating the playlist description once again.  


You can get your downloaded music back once the clean reinstall is complete. Here you can find more info on how to do that. 


Hope this helps. Keep us posted.

Hey Ivan, 


I did both a reinstall and a clean install of Spotify trying to get playlists to update; however, this doesn't solve the underlying problem which seems to be with how the data is sent and received from the server (specifically the update request). 


Perhaps the playlist description change takes a while to propagate to the server? This could make it seem like the update didn't go into effect when it makes a request for the description upon switching from one playlist back to the updated. The reason I think this is because sometimes when I come back the next day to check the description, the playlist will be updated to the new description. Perhaps the old description gets cached? Not sure what the exact issue is but there seems to be a delay in the update that makes it seem like there is a problem with updating entirely (which is why so many people are having this issue).  

Hey @missmccallkay,


Thanks for getting back to us.


Can you confirm that this also happens when you create a new playlist and try updating the description?

If not, then it might be an issue with the individual playlist - in this case, we recommend creating a new playlist and copying all your songs over.

If it's happening no matter which playlist you're trying to rename, do you mind trying the above, only this time:

  • log in on a different device, but using the same account
  • log in on the same device, but using a different account?

Let us know how you get on!

March 2020 and this is still an outstanding issue.... pretty frustrating

Marked as solution

Hi! I was having the same really frustrating issue for a long time. I can't guarantee this will work forever, but it is working for me right now. When you make the edit and press save, then download the playlist. 
I'm hoping that eventually I can un-download the playlist and free up space, but this seems to be working now.

This also worked for me (save then download). Embarrassing Spotify can't fix this simple issue after so long.

April 2020 now, and the problem of playlist description edits not being saved persists, but seemingly improved because I'm finding it an intermittent problem.  Sometimes the changes I make to a playlists description ARE saved, and sometimes not.  Earlier posts about this problem didn't mention it being intermittent, so I guess this is an improvement.


It seems like time is involved, leaving a playlist open for a while after revising its description seems to help make the changes stick.  Also playing a track in that playlist seems also to increase chances of success. 


I haven't tried the dowload the playlist and then undownload it trick, but it sounds promising.


Still, these are all annoying and kludgy workarounds for a problem that should be fixed and still isn't, at least not entirely. 


It's particularly annoying because the description field usually contains specific details and reminders that are put there so they won't be lost or forgotten.  It's like if the ink you used to fill in your dayplanner faded and disappeared.  Very frustrating!

Maybe you guys should be fixing bugs and introducing new features if you want increased sales and retention. This is a pretty basic bug to fix, but it's clear this company this doesn't care and more reasons to not spend money on this product. 

This is not a solution, because the problem is about the apps. However, I would say that those upthread could confirm that the changes they're making are taking place by checking in the browser player. I found this thread because I'm having the same problem (while simultaneously cross-checking with mobile, and finding that the changes exist and then disappear nearly immediately after appearing there) and just had the thought to use the web player to check them out. The most recent versions of the three playlist descriptions I changed did appear! Two of the playlists are new playlists I created just today, and one is a playlist I have been using since November 2016. 

Wow that works. So bizarre and specific. I don't know how you ever found this workaround, but thank you! Hope they fix it soon

I am having the same f*cking problem and it is now almost july in 2020. wth spotify?!!

Hi everyone, 


Thanks so much for reporting your own issues with playlist descriptions/images (really the UPDATE of an existing playlist) not working and often reverting. I was able to update an image yesterday after 3 times trying to update, and what I think might be happening is that the update is just SUPER delayed so it looks like it's not getting updated, but if you were to check back the next day the description would be changed.


Definitely still a frustrating bug that should be fixed by Spotify devs because otherwise, it looks like any changes you made to an existing playlist were not updated. Please submit a bug ticket for this and have a developer look into it. 


Let me know if anyone else has seen this be the case. 

Thank you so much!

okay so i logged into a different account on a web browser (not the app) and i check my playlists, most of the covers have updated for me but it just doesn't seem to work in the actual application lol its so frustrating

Same here. I'm using a late 2018 MacBook Pro (macOS Catalina 10.15.6), and I'm on the latest Spotify desktop version as of right now. Descriptions aren't updating on my mbp only; I see the new description on my iPhone and Browser version of Spotify just fine. I really really want this issue resolved; it may not seem like a big deal, but it's super annoying to not see your descriptions update real time. Please fix it soon, especially since it seems like this issue hasn't been addressed in quite a while. 

Suggested posts