Playlist order mixing up when deleting a song

Playlist order mixing up when deleting a song

momonumana

Plan

Premium

 

Device

Macbook Pro 2018

Operating System

macOS 11.2.3

 

My Question or Issue

 

Hi, I use Spotify on a mac. Regularly when I remove a song from a playlist it changes the order of the other songs in the playlist. This happens more often when I remove multiple songs at once. Often the song to remove stays in the playlist. A similar thing happens when I move multiple songs around in the playlist, they do not always stay in the original order. But especially when deleting it is really frustrating to curate a playlist as I often need to redo my choices of order. 

 

 

 

Reply
12 Replies

Mihail

Hey @momonumana,

 

Thanks for reaching out to the Community.

 

Could you make sure that Custom order is selected in the playlist sorting options? If that doesn't do the trick, let us know if this issue persists once you've performed a clean reinstall on the affected device. We recommend this step since it'll get you the latest app version with all necessary updates and remove any corrupted files from previous installations.

 

Hope this helps. Keep us posted on how it goes. 

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

momonumana
Hi, yes, I have Custom Order selected. I also made a clean reinstall. Still the same issue.

Deleting songs results in songs not deleted but the playlist order being mixed up. It seems to happen after rearranging the playlist. Sometimes they disappear and then reappear in a previous order. A second deletion then usually works. Also, moving multiple songs changes the order of the songs being moved.

Mihail

Hey @momonumana,

 

Thanks for getting back to us.

 

Could you test if the same thing happens on our web player? If you have the option to borrow a friend or family members account and share if you observe the same behavior there, that would help us a lot in getting to the bottom of this.

 

Keep us posted, we'll be on the lookout for your reply. 

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

momonumana
It does not seem to happen in the web player. But in the web player I can not move or delete multiple songs at once. If I only move and delete single items, I do not get the problem on the desktop either.

I will try to find someone else to check if they experience the same.

Mihail

Hey @momonumana,

 

Thanks for getting back to us.

 

It would seem that something is interfering with the app on that specific device. One thing that you can try is removing any Spotify entries in the hosts file you can find. Even though it was written for another topic, this page has instructions on how to do this.  

 

If that doesn't fix things, we'd a appreciate a recording of the issue. The results of testing another account would also be of great help.

 

Keep us posted. We'll be on the lookout for your reply. 

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

momonumana
Thank you. I do not have any Spotify entries in the host file. Also I did add another note to my last reply that seem not to appear in the thread:

To clarify. If I only move single songs then I can delete multiple ones without an issue. The problem only occurs once I start moving multiple songs at once. Then even a single delete may cause the issue.

And yes, I will try to test it with another account.

momonumana

I checked at a friends mac, he uses macOS Catalina instead of Big Sur as I do. His Spotify looks quite different, like an older version, but no update seems available for him. His version number is 1.1.54.592.gc0b20638 mine is 1.1.54.592.gc0b20638-a. In his version the problem does not appear.

Jeremy

Hey there @momonumana,

 

Thank you for your reply and confirmation.

 

You are on the new desktop experience which is why your app looks a bit different.

 

Can you have someone log in to your device - such as a friend or a family member to see if the issue persist.

 

We'll keep an eye out for your reply.

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

ginsunuva

Same issue here on same OS after new update.

 

It seemed to have occurred to only certain playlists, and it happened after I deleted something while it was sorted by duration.

Novy

Hey @ginsunuva

 

Thanks for reaching out about this, and welcome to the Community 🙂 

 

Could you let us know if you've already tried any of the previous troubleshooting steps? This will help us give you better suggestions. 

 

We'll keep an eye out for your reply. 

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

ginsunuva

I have tried relaunching, but not reinstalling, the client so far.

 

It seems to have occurred to only one of my playlists thus far, and it happened after I deleted something while it was sorted by duration.

Novy

Hi @ginsunuva

 

Thanks for getting back to us. 

 

We'd recommend making sure to follow these steps when reinstalling the app, as it will help deleting any cache that might be causing trouble. 

 

You could also give it a try using another internet connection to see if there's any difference.

 

Let us know how it goes.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts