Help Wizard

Step 1

NEXT STEP

Skipping audio when OSX screen locks

Solved!

Skipping audio when OSX screen locks

Description

When I listen to spotify on my mac, I'm not always using the mac for anything else for a while, and the screen will goto sleep (not the whole computer - just the screen). Once it goes to sleep, spotify will start skipping. It's not 100% of the time, I'd say its about 50% of the time. It gets annoying enough that I usually just unlock it and it returns to normal (no skips!). 

 

A more detailed description, using numbered steps

1. Play music via spotify

2. Do other things (not on this computer)

3. Computer locks (screen goes to sleep) after a 15 min inactivity window

4. ~50% of the time, spotify will start skipping/hesitating. 

5. I unlock computer

6. Spotify returns to normal

7. I turn caffiene on (taskbar app that keeps computer from falling asleep for pre-defined window of time)

8. My mac is open to whoever wants to use it if I walk away from my desk. 😞

  

What I expected to happen

No change in spotify's ability to stream while computer is locked/screen sleeping

 

What actually happened

skipping/hesitating audio while screen locked/sleeping

 

My Operating System

OS X 10.10.3 (just updated yesterday, problem has happened for a while on previous versions - It just happened again today and I decided to finally deal with it.)

 

My Spotify version

1.0.3.101.gbfa97dfe

 

My internet provider and country

Comcast Business, USA (I use spotify primarily at work)

 

My username

1220939874

 

Do you have any screenshots you can attach to more clearly explain your issue?

nope 

Reply

Accepted Solutions
Marked as solution

SOLUTION!

 

Okay so the feature is called App Nap - it's a great feature and save a lot of power and system usage. However in this case with Spotify it's a pain. 

 

There is a solution though! You can disable app nap for spotify easily on 10.9, 10.10 requires a simple terminal command - once done restart spotify and you're away.

 

Solution is here: http://skylarsch.com/2015/02/25/one-month-with-spotify.html

 

I hope this helps! 

View solution in original post

14 Replies

Hello and welcome!

Just to be sure, is your Mac set to only turn off the screen or actually go to sleep?

Both "computer sleep" and "display sleep".

iTunes handles it just fine and keeps playing. Spotify plays but has trouble keeping up.

Try turning off the computer sleep, that might help.

It maybe due to iTunes playing local songs saved on the HDD, while Spotify streams it from the net.

I'd rather not have my computer open - sometimes I wander away from my desk for a while and come back. I like that my computer sleeps (and locks) when I let it idle for 10+ minutes. iTunes streams half my music via iTunes match, so it's not that different.

I've been noticing this issue as well. This is a new issue for me, I only started noticing it in the past week or so. 

Same issue, but my Spotify also skips when im working on an app in another "desktop". Assigning spotify to all desktops solves the issue. (Not the sleep issue thought)

Experiencing the same issue.  Nothing in the logs.  When displays are put to sleep (ctrl + shift + eject), or when screensaver starts

Pinning spotify to all desktops did not resolve the issue.

 

imac5K, 16GB ram, yosemite 10.10.2

 

 

help!  Use spotify to listen to music at night

 

I have a feeling this could be DAC related.  As I use the NAD 3020 instead of the internal sound card.  I've NOT had this issue with Hifiman EF2A...  

 

I've switched the USB port on the back... problem seeeeeeems to have gone away.  Will post if I find anything else 🙂

 

Thoughts anyone?

I have the same issue. I know the cause but not the solution. 

 

The cause is in MAC OS X 10.10 - they introduced a feature where apps in the background are allocated less memory to allow the app in focus to use the maximum resources on the system. The same applies when the computer locks.

 

I'm investigating if there is a way to specify what apps are allowed to use all the memory they require in the background, but so far no answers. 

Makes complete sense! Would love to know if there is a way to whitelist a process... Maybe give Spotify process a higher nice value?
Marked as solution

SOLUTION!

 

Okay so the feature is called App Nap - it's a great feature and save a lot of power and system usage. However in this case with Spotify it's a pain. 

 

There is a solution though! You can disable app nap for spotify easily on 10.9, 10.10 requires a simple terminal command - once done restart spotify and you're away.

 

Solution is here: http://skylarsch.com/2015/02/25/one-month-with-spotify.html

 

I hope this helps! 

will test with `defaults write com.spotify.client NSAppSleepDisabled -bool YES`

Noticed it did require a restart of Spotify before it worked and had to use the command line option OSX 10.10.5. Thanks for the link!

In case the link dies, here is the console command

```

defaults write com.spotify.client NSAppSleepDisabled -bool YES

```

Brilliant. This has been driving me crazy. Typed the command line and seems to be working so far. Thanks!

Suggested posts