Announcements

Spotify Opening Automatically On Computer Startup

Spotify Opening Automatically On Computer Startup

Hoppin

Since upgrading to macOS High Sierra Spotify has been opening up on computer startup.  Found that the Spotify / Preference / Settings / Advance Setting / Startup & Window Behavior / Open Spotify automatically after you log into the computer / option was set to "Yes".  Change the setting to "No" serveral times.  Each time Spotify continued to open upon computer log in and the option had changed back to "Yes".  How can Spotify opening automatically on startup be stopped on an iMac running masOS High Sierra?

Reply
7 Replies

oneilljack

Same behaviour for me. This is not acceptable. I have disabled this option several times and also disabled "open at startup" in the mac menus.

 

If this behaviour continues, I will delete the app.

jkbjkbjkb

I have the same issue. Currently running version 1.0.68.407.g6864aaaf on High Sierra. It was also occuring on the previous version. It's a bit weird that other changes to the settings/preferences are properly saved and respected.

 

 

BruceC

Same issue for me and I will end up removing the app is they can't supply a fix or answer.

Hoppin
Spotify no longer opens automatically on my iMac startup. Thank you Spotify.

mikeritter

The solution over here works.

 

https://community.spotify.com/t5/forums/v3_1/forumtopicpage/board-id/windowsdesktop/message-id/61327...

 

System Preferences > Users and Groups > Login Items > Spotify > Minus Sign [-]

 

It essentially overrides the option to automatically start set (presumably) on install.

 

The setting from Spotify > Preferences is (presumably) local and not system.

 

Cheers!

Hoppin
Thank you for your reply and clarification of the macOS High Sierra and Spotify settings. My mac OS High Sierra Version 10.13.2 setting was set to System Preferences > Users & Groups > Login Options > Minus Sign [-] when the Spotify opening automatically problem was reported. Assume there was a bug in the Spotify > Preferences > Show Advanced Setting > Startup and Window Behaviour > Open Spotify automatically after you log into the computer option which has been fixed. At the time fo the problem this was a slide off / on option which reset itself from off to on. It has been changed to a drop down Minimize option and Spotify is no longer opening automatically at start up. Hope this is helpful.

SabinaDavora

Spotify wasn't on my Login Items list. I'm hoping changing the preferences to "no" will work. They certainly hide that thing don't they?

Suggested posts

Env: prod