Help Wizard

Step 1


Cannot search artists or songs [Webplayer]


Cannot search artists or songs [Webplayer]







Operating System

( Windows 10 )


My Question or Issue

I have noticed that the search feature works on my web browser when I'm not logged in, but will not work when logged in to spotify. The computer App has the same issue as well as on all browsers. (Chrome, FF, IE)

I get the 'Oops something went wrong' when ever I search for anything.

spotify screen 1.jpg
spotify screen 2.jpg

Accepted Solutions
Marked as solution

7 Replies

Hey there @Ruanation


Thanks for reaching out - we’re here to help!


We'd suggest you first restart the network device (router or modem), then log out and log back in to the Spotify app. This should fix the issue you're experiencing. 


If that doesn't do the trick, try a clean (more thorough) reinstall of the app. This way you can start afresh with Spotify on your device. Check out this help page in order to find the steps for clean reinstall on your device. 


It's also a good idea to try the web player in a private/incognito window. This step makes sure you avoid issues with your browser's cache. If this doesn't help try again in a different kind of browser.  


Hope this helps. Keep us posted. 

Hi, Thanks for responding.

I added images of what it looks like in incog mode after instructions were followed.
I even bothered to try flushing the DNS with CMD in admin mode after the incog caps were taken.

I no longer have any traces of the spotify app on my computer, just the web based player.

I recently tried to use my playstation 4 app and it is working fine. Same for android. Can search all day long on those.

Marked as solution


Took me a long while but I managed to find the solution.

I tried it, it didn't fix the search

Hi folks, 


Thank you for posting on the Community!


@liperat Could you tell us which troubleshooting steps you have tried so far? This way we won't repeat the same ones you did and help you fix this issue.


Keep us posted. 

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I'm tired of repeating it myself


I tried to clean the cache, it didn't work, I tried to change account, it didn't work, I cleaned the host file, it didn't work, I tried to use the **bleep**ing app, it didn't work

Suggested posts