Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

How to stop smart shuffle from randomly turning on

How to stop smart shuffle from randomly turning on

I have a Windows 10 Laptop and every time I minimise and then maximise my Spotify window smart shuffle turns back on, this is really annoying as I open and close Spotify a lot and I don't even want it on shuffle never mind smart shuffle
Reply
20 Replies

I have this same problem, plus I didn't even know it existed! I just turned on spotify one day last week and it starts making suggestions in my liked songs list. I HATE suggestions, and ALWAYS have them turned off. If I want a song, I'll search for it! And the suggestions are always awful, bordering on offensive or insanely boring.

 

Also, I really worry about kids ending up with inappropriate suggestions, since it's so easy to activate smart shuffle accidentally AND it turns itself on. I can easily see parents, especially if they don't know about the feature, letting their kids listen to spotify and not knowing what was being heard. And the kids wouldn't necessarily know what was happening. 

Hi there,

 

Thanks for reaching out. You should always have control over a setting like this, so this behaviour is quite strange. Could you send us a video of this behaviour so we can see exactly what's going on? If the files are too large to attach here in the Community, you can send them to us via Google Drive or as unlisted YouTube videos.

 

Keep us posted.

JoanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

it happens to me too on a windows 11 laptop
and on my iphone it defaults to smart shuffle and wont let me change it to regular shuffle

 

Hi @sufko,

 

Are you using the desktop app? If so, try performing a clean reinstall to see if that does the trick. As for your iPhone, note that in some regions Smart Shuffle is the default listening method for free users.

 

Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Doesn't seem like strange behaviour 😛 

Yeah, smart shuffle doesn't want to be turned off. It happens, on my Android phone and Apple desktop, that I'll turn off shuffle, which activates smart shuffle, which I toggle off, which will toggle itself back onto smart shuffle.

I usually have to open the queue in order for the 'shuffle icon' to reflect 'smart shuffle' (as the queue will show smart shuffle tracks before the icon re-displays smart shuffle by itself).

So it seems it doesn't want to be turned off... and I know that I have to go through this process before I can move on.


(To add, this adds onto the wait time of when the app is first opened while connected to WIFI, as updates (The Home display?) overtake the ability to access and play a playlist - I assume that priority is to see the updated Home Screen suggestions, which makes sense. It just builds a sense of a wait time to play a playlist.)

 

I love using Spotify for its music suggestions - which I feel like I use! so options like smart shuffle are great. I just get concerned that paid promotions and getting certain music in my face is preventing me from enjoying and discovering my own preferences. Sorry to go on : the new feature of adding to multiple playlists at a time was also very appreciated! 

Hey @Jehru,

 

Your feedback is much appreciated!

 

Is it possible to send us a video of this behavior so we can take a closer look? We'll also need it in case this needs to be forwarded to our tech team.

 

Also, please share the model, OS version and Spotify version of the affected devices.

 

Thanks!

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I can confirm the same bug, at least in the windows app. I would upload a video that I have, but it says I have no permission.

Hey @juantxorena,

 

Welcome to the thread!
You can try sending us a link to the video recording after you upload it anywhere else 🙂
Google Drive / YouTube, etc. would do the job! 
Just make sure the access to it is set to public and we'll gladly take a look 🙌🏼

And also, we'd love it if you could share with us the model, OS version and Spotify version of the affected devices as requested by @MihailY so that we can also provide that info to our tech folks.
Many thanks in advance!

VasilModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

https://streamable.com/vhv0do

Windows 11
Spotify latest

In order to fix it I had to open the Spotify app from my phone and put it to the normal shuffle and then it didnt change to smart

Hi there @YuzGz

 

Thanks for getting in touch about this and sending us this info. 

 

Could you let us know which troubleshooting steps you've already tried? That way we can avoid repeating any steps.

 

If you haven't performed a clean reinstall of the app yet, we suggest that you do so by following these specific steps. 

 

If the issue persists, could you let us know if this happens across devices or only on your PC? Additionally, make sure to send us the exact Spotify version of your PC. 

 

We'll be waiting for your reply. 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

heres what worked for me:

Open spotify app on your phone

Play music on your pc

It will show smart shuffle, change it to the normal shuffle on the phone app
Then it should stop changing to smart shuffle on the pc from now on

 

 

 

 

same here - on my windows computer smart shuffle will not turn off, even though it is physically 'turned off' I still get random songs in shuffle mode!?!?!? normal shuffle is switched on but i still get 'smart' songs that I do not want... I simply want to shuffle the songs in one of my playlists. to avoid 'smart' suggestions being played i have to play my lists in order, which sometimes I simply do not want to do!!! get rid of smart shuffle or make it turn off!!

yeah this is annoying. I want to listen to my music not whatever B.S. Spotify is forcing me to listen to. My main playlist has 2.4k songs that I like. I don't want it messed with. If I listen to a playlist with a specific mood Spotify is unable to understand what mood I am going for so my sad breakup will suddenly have something Christmas recommended. I turn off the feature and 2.5 seconds later it turns back on. I can't even go no-shuffle. I want them to remove the feature if they can't fix it. I am also on premium..

it won't even let me play no-shuffle. I also can't disable it on phone or windows 10...

same I cant fix it with phone nor windows 10 either. seems like this issue has been happening for way too long to not be fixed. i haven't found a single solution

Hello @hatoku

 

Thank you for reaching out, Welcome to the Community. 

 

Have you tried performing a clean reinstall like the other mods suggested in this thread? 

 

Please send us a video of this occurrence that we can forward it to our tech team for further investigation. Also please share with us the exact model, OS version and Spotify version of the affected devices as this is crucial information for us to be able to look into things.

 

We will be waiting for your reply.

MartinModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Doing this fixed it for me. I think the playlist settings were taking priority and kept resetting it back to what they were set to. Changing that stopped it from happening. At least for now.

Untitled.png

@Joan 

Hi there, I seem to be having the exact same problem as most people on my laptop, and it happens when I switch windows or when my computer goes into rest mode. Here is a video link to give you a visual of what is happening. https://youtu.be/LzrrttclOsk

Suggested posts