Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Media keys no longer work


Media keys no longer work


My media keys used to work to play, pause, skip forward/backward, etc. in Spotify, and other applications when Spotify is running. Suddenly, my media keys have no effect.


A more detailed description, using numbered steps

1. Open Spotify

2. Start playing music

3. Click my "Play/Pause" media key



What I expected to happen

Music pauses, and resumes upon another click


What actually happened



My Operating System

Windows 7 (64 bit) AND Windows 8.1 (64 bit)


Do you have a Service Pack installed?

Windows 7 is Service Pack 1, Windows 8.1 has no Service Pack


My Spotify version


My internet provider and country

Service Electric, USA


Did you do a clean install of your current Windows version or did you upgrade from a previous version?

Clean installs on both


My username



Do you have any screenshots you can attach to more clearly explain your issue?


88 Replies

Well, I was sure I had a problem with my keyboard but you sir helped me a lot today ! Thanks !

aaah thaaankksss... dont have google play, or windows media services, but this way works...




I have the same issue, BUT i don't havbe Google Play Music as an exttension in Chrome!! So I don't even get the chance to disable the extension or delete global hotkeys!!


On top of that, even when I close, the media keys don't work


PLS help me! This is driving me nuts


That worked... but WHY?!
Marked as solution

In my case was the Plex extension, so it can happen with other media related programs, be aware.

Honestly have no idea why disabling Google Play Music in Chrome fixed this problem... we should go and have a  word with Google about this one!

Mine wont work and I dont have google music, I just switched keyboards 😧

I am having this issue on my nook hd tablet. I disabled the built in google play music and restarted my device, but my buttons still do not respond to being pressed. I can play a song, but it refused to go to shuffle mode or off of repeat, and the play and pause button will work sporatically, only if I spam press the button. This doesn't work for the other ones. It is registering the presses, the button is going down in responce to my touching it, but no change occurs.


I don't have Google Play either but it turned out I had iTunes open and the Media Keys were just getting confused. Closed down iTunes and it worked like a dream. Maybe see what other players may be running in the background? 🙂

This also happens with the Plex extension version 2.8.4 on Google Chrome 53.0.2785.116 m (64-bit). Disabling the extension helps.

Awesome! Stupid Chrome browser!

If you have a mac, in system preferences under keyboard settings, make sure you have 'Use all F1, F2..." turned off. I was being stupid and was trying to use the media keys by themselves with this setting turned on. This is probably not the solution for most people's problem with this but may help one or two. 

I downloaded the new update for Spotify and my Razer Naga Multimedia Keys do not work for Spotify at all. When I reopen and close Spotify I can press one of my multimedia keys but Spotify goes on a burst of "pauses" for a song if I press my "play/pause" multimedia key.  If I press my "skip track" button Spotify goes on a burst of "skips" on a playlist. After a while the skipping and or play/pause stops but the multimedia keys again do not work for Spotify.


I've tried the Human Interface suggestion of setting it into "Automatic" and "restarting" it in services and that did not help.

I've disabled the Windows Media Player Sharing Network on the services and that did not fix the problem.

I do not have Google Play on my chrome. I do not have iTunes and I do not have Windows Media Player on my computer.

I've also clean uninstalled/reinstalled Spotify.

I really believe this is a Spotify problem. As this problem occured when I updated my Spotify.


Can anyone help me?

1st thing is Razer Naga? That's a mouse and as far as I am aware there are not any media keys on it (I have a Naga). I am assuming you are referring to the Blackwidow, Ornata, or other Razer keyboard (I have a Blackwidow Ultimate 2014). I noticed you said you do not have Google Play Music on Chrome, but check for sure that it is still not in your installed plugins (I have disabled mine multiple times because it seems to come back after Chrome updates etc.) If that does not fix it check your Razer Synapse profile. Check to make sure nothing has been changed for those function keys, and also check to make sure ther isn't a Synapse update. Next try restarting Synapse (exit from the system tray and then reopen the program). Unplug and replug in your keyboard. If those don't work come back and ask again. I will look for another possible solution in the meantime.

You're right in there not being exclusive "multimedia" keys on the mouse itself but I did use Razer Synapse to program some of my mouse buttons (on the side) to be multimedia keys. I did update Razer Synapse, and I also did a clean install of the Razer Synapse once before. I had this same issue with the versions before this last Spotify update. Surprisingly the update before this one managed to work again. So this has been an oncurring problem for me for some time I've just hadn't bothered to post until now. I've also went ahead and updated my Realtek HD Audio software so that is up to date as I found another post mentioning that. 


As of right now I still have the same problem posted above. Still no fix as far as I'm aware for me.


Edit: Avira Antivirus (my antivirus) seems to stop Spotify when I open it. Is there some connection between my anytivurs and Spotify?

Just wanted to confirm that disabling the "Google Play Music" extension in Chrome solved the problem instantly. Thank you for the solution!

Marked as solution

Regardless of what extensions you have, you can change it by going into the Extensions setting of Chrome, scroll to the very botton and select "Keyboard shortcuts".

There you can enforce that whoever has control of the media keys, that it is in Chrome only and not globally.  I set my Plex extension to be in Chrome only and it solved the issue.



Suggested posts